summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-24 13:19:50 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-24 15:29:36 +0200
commita93eef9e2f8b6d38a131efe7993caf3f747dc137 (patch)
tree0657943c6414af7c6c67e1155e062f06bb4532cc /sci-mathematics
parentsys-fs/unionfs-fuse: 3.4 (diff)
downloadgentoo-a93eef9e2f8b6d38a131efe7993caf3f747dc137.tar.gz
gentoo-a93eef9e2f8b6d38a131efe7993caf3f747dc137.tar.bz2
gentoo-a93eef9e2f8b6d38a131efe7993caf3f747dc137.zip
sci-mathematics/cryptominisat: bump to 5.11.14
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cryptominisat/Manifest1
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index 698b6506cda9..4454421ae387 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1,2 +1,3 @@
DIST cryptominisat-5.11.11.tar.gz 1012869 BLAKE2B 768ae936380c05f3129ac642fe8e7c3581824f8be8e02c7d6709fbb8ca1e43eae04ba6d16d441063ed4cbe597a64ee357fa8b45e3f740a6cf11c00f9225b6b5d SHA512 21827627a1765b760df4635f3606ba83c76bac52217120a0b4c97bcb05526fe6cf7325dff04385525f763f20a0371586dc929eb3c57023b3367a8af9ea8e947a
DIST cryptominisat-5.11.12.tar.gz 1013147 BLAKE2B f69f8dac97aaddcff89039aa43e786058befe5b86bed98059bda84d7559601ef6d39dcbf296a0c075d0ffae54054f7b3e78db371c8c66d4290b78dcd562bb977 SHA512 f6e9bb3f561e066f5fa228fcd0d8887333b251b88f7838c3ac0c130c2b7cd5ae46ff6272b4603a898efa67b3faeef22d01697b60e565d2dc6bfc890c7dc56a93
+DIST cryptominisat-5.11.14.tar.gz 1013009 BLAKE2B 83fc29694caa3a3883f617affaf9906da6f9ded11a6894e92274c47c4df202b7ef2a404f25781348752a471564a6469aacea9a79d466d01d3d703e4df7a357a8 SHA512 efcec05f515f1c83d5ecc96cb21ad956bae52563749412cd9d0279b0780c0f91b7143ebc5524dc7d45d159e921a88503248ccef6d2ef37875e78b7a163ddb3ce
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild
new file mode 100644
index 000000000000..8eb2f8619f84
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/msoos/${PN}.git"
+else
+ SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0/${PV}"
+LICENSE="GPL-2 MIT"
+RESTRICT="test" # Tests require many git modules.
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}