summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-04-26 13:10:55 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-04-26 13:10:55 +0700
commit786377e80650a704eda3ffa754839a1e63bf1305 (patch)
tree1d6c23763374c399c7b8746033bc63d6fbfa76d3 /sci-mathematics
parentapp-misc/task: remove old (diff)
downloadgentoo-786377e80650a704eda3ffa754839a1e63bf1305.tar.gz
gentoo-786377e80650a704eda3ffa754839a1e63bf1305.tar.bz2
gentoo-786377e80650a704eda3ffa754839a1e63bf1305.zip
sci-mathematics/fricas: bump to 1.3.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/fricas/Manifest1
-rw-r--r--sci-mathematics/fricas/fricas-1.3.2.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/sci-mathematics/fricas/Manifest b/sci-mathematics/fricas/Manifest
index 804b46eee395..80f19774eff8 100644
--- a/sci-mathematics/fricas/Manifest
+++ b/sci-mathematics/fricas/Manifest
@@ -1,2 +1,3 @@
DIST fricas-1.3.0-full.tar.bz2 10459788 SHA256 d4ceb6bcf4049196130d463dc7442dd206fd9cde0634f3e2f70add2e2c774f03 SHA512 fd084c3d3ada76424b0159eff76660872da63c1e25f392d98bc7175b37c05fe23a117587addc89828ff38a368f5161d34febcc269f530710ff7da6b53860653f WHIRLPOOL c334c42ee83f676ce9640870e4ddf42a2a3c034570c173ec633c6eecf45d3e2d14f9e6e9fa4240d4f090fa0b1ddfaa3e4b117d530dc6f3c9d70a9b1a399cd188
DIST fricas-1.3.1-full.tar.bz2 10522387 SHA256 7d4a768aed086aefa332930787dbc1be810aeded9385ae2b7205d6c1827c5c30 SHA512 d492686fc03ed704cc015ec0ba250ab7928b637ff6ef8cf1aa924190e7fe22bd63a512074439dbf7ce44dce786d51ad5e27857522a1e21136b4b8d6cf014c486 WHIRLPOOL 143c7ef847292ac37ae9f1322ec4d93e3879e0fc9b602d727b870c808569aa2dc6c4f76e0f1880ec3bb2915e713fa773c1e936be2b9059b73e7d5786efeef297
+DIST fricas-1.3.2-full.tar.bz2 10523665 SHA256 798b123e61f3566e6b1b367c235f5b4599a9c737b938aa71f32d0aabb7db439d SHA512 679dffbe8a991d4ae3d6667a6163337ffa24d48b9d1d776ba1a39569cb3b9f17e8d484075746b75b7eb6bbe5b9d26af3e526850a19118274988b9e88ad52a679 WHIRLPOOL 2ce62a2917a6378d75e844ba0b63d1386552698181892ad9f1d519019c89525c20b19b6ea6a7e9f93b656529c7bd4f1f2f2c6a7f571fec1e2713a4faa0d3e41b
diff --git a/sci-mathematics/fricas/fricas-1.3.2.ebuild b/sci-mathematics/fricas/fricas-1.3.2.ebuild
new file mode 100644
index 000000000000..315a133b047b
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.3.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+inherit multilib elisp-common
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Supported lisps, number 0 is the default
+LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
+# Version restrictions, . means no restrictions
+REST=( . . . . . . )
+# command name: . means just ${LISP}
+COMS=( . lisp . ecl . ccl )
+
+IUSE="${LISPS[*]} X emacs gmp"
+RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( virtual/emacs )
+ gmp? ( dev-libs/gmp:= )"
+
+# Generating lisp deps
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ LISP=${LISPS[$n]}
+ if [ "${REST[$n]}" = "." ]; then
+ DEP="dev-lisp/${LISP}"
+ else
+ DEP="${REST[$n]}"
+ fi
+ RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
+done
+if [ "${REST[0]}" = "." ]; then
+ DEP="dev-lisp/${LISPS[0]}"
+else
+ DEP="${REST[0]}"
+fi
+RDEPEND="${RDEPEND} ${DEP}:="
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ RDEPEND="${RDEPEND} )"
+done
+
+DEPEND="${RDEPEND}"
+
+# necessary for clisp and gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP n
+ LISP=sbcl
+ n=${#LISPS[*]}
+ for ((n--; n > 0; n--)); do
+ if use ${LISPS[$n]}; then
+ LISP=${COMS[$n]}
+ if [ "${LISP}" = "." ]; then
+ LISP=${LISPS[$n]}
+ fi
+ fi
+ done
+ einfo "Using lisp: ${LISP}"
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x) $(use_with gmp)
+}
+
+src_compile() {
+ # bug #300132
+ emake -j1
+}
+
+src_test() {
+ emake -j1 all-input
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc README FAQ
+
+ if use emacs; then
+ sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
+ -i "${D}"/usr/bin/efricas \
+ || die "sed efricas failed"
+ elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}