summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2017-02-01 19:40:15 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-01 23:39:04 +0100
commit5023dc2db5f79ef9d2339417ee606f44490ce08b (patch)
tree67487a269a49a024f1092d9bc03693035c75f6bd /sci-mathematics
parentsci-mathematics/calc: remove unused patch (diff)
downloadgentoo-5023dc2db5f79ef9d2339417ee606f44490ce08b.tar.gz
gentoo-5023dc2db5f79ef9d2339417ee606f44490ce08b.tar.bz2
gentoo-5023dc2db5f79ef9d2339417ee606f44490ce08b.zip
sci-mathematics/freemat: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/3764
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/freemat/files/freemat-4.0-gcc45.patch208
-rw-r--r--sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch14
-rw-r--r--sci-mathematics/freemat/files/freemat-4.1-have_fftw.patch78
-rw-r--r--sci-mathematics/freemat/files/freemat-4.1-local_libffi.patch13
-rw-r--r--sci-mathematics/freemat/files/freemat-4.1-portaudio.patch10
-rw-r--r--sci-mathematics/freemat/files/freemat-4.1-use_llvm.patch29
6 files changed, 0 insertions, 352 deletions
diff --git a/sci-mathematics/freemat/files/freemat-4.0-gcc45.patch b/sci-mathematics/freemat/files/freemat-4.0-gcc45.patch
deleted file mode 100644
index 7492e16b783e..000000000000
--- a/sci-mathematics/freemat/files/freemat-4.0-gcc45.patch
+++ /dev/null
@@ -1,208 +0,0 @@
-Fix building with gcc-4.5
-
-http://bugs.gentoo.org/show_bug.cgi?id=318045
-
---- libs/libFreeMat/Array.cpp
-+++ libs/libFreeMat/Array.cpp
-@@ -465,7 +465,7 @@
-
- void Array::set(const QString& field, ArrayVector& data) {
- if (isEmpty() && m_type.Class != Struct)
-- *this = Array::Array(Struct);
-+ *this = Array(Struct);
- if (m_type.Class != Struct) throw Exception("Unsupported type for A.field=B");
- StructArray &rp(structPtr());
- if (isEmpty())
---- libs/libFreeMat/Math.cpp
-+++ libs/libFreeMat/Math.cpp
-@@ -1590,9 +1590,9 @@
-
- Array Not(const Array& A) {
- if (A.isScalar())
-- return Array::Array(!A.toClass(Bool).constRealScalar<bool>());
-+ return Array(!A.toClass(Bool).constRealScalar<bool>());
- const Array &Abool(A.toClass(Bool));
-- return Array::Array(Apply(Abool.constReal<bool>(),notfunc));
-+ return Array(Apply(Abool.constReal<bool>(),notfunc));
- }
-
- Array Plus(const Array& A) {
---- libs/libFreeMat/Operators.hpp
-+++ libs/libFreeMat/Operators.hpp
-@@ -142,11 +142,11 @@
- if (!Bcast.isScalar()) Bcast = Bcast.asDenseArray();
- if (Acast.isScalar() && Bcast.isScalar()) {
- if (Acast.allReal() && Bcast.allReal()) {
-- F = Array::Array(Op::func(Acast.constRealScalar<T>(),
-+ F = Array(Op::func(Acast.constRealScalar<T>(),
- Bcast.constRealScalar<T>()));
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(T(0),T(0));
-+ F = Array(T(0),T(0));
- Op::func(Acast.constRealScalar<T>(),
- Acast.constImagScalar<T>(),
- Bcast.constRealScalar<T>(),
-@@ -155,7 +155,7 @@
- }
- } else if (Acast.isScalar()) {
- if (Acast.allReal() && Bcast.allReal()) {
-- F = Array::Array(Tclass,Bcast.dimensions());
-+ F = Array(Tclass,Bcast.dimensions());
- T* ret = F.real<T>().data();
- const T& Ap = Acast.constRealScalar<T>();
- const T* Bp = Bcast.constReal<T>().constData();
-@@ -163,7 +163,7 @@
- for (uint64 i=0;i<q;i++) ret[i] = Op::func(Ap,Bp[i]);
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(Tclass,Bcast.dimensions());
-+ F = Array(Tclass,Bcast.dimensions());
- T* Cr = F.real<T>().data();
- T* Ci = F.imag<T>().data();
- const T& Ar = Acast.constRealScalar<T>();
-@@ -175,7 +175,7 @@
- }
- } else if (Bcast.isScalar()) {
- if (Bcast.allReal() && Acast.allReal()) {
-- F = Array::Array(Tclass,Acast.dimensions());
-+ F = Array(Tclass,Acast.dimensions());
- T* ret = F.real<T>().data();
- const T* Ap = Acast.constReal<T>().constData();
- const T& Bp = Bcast.constRealScalar<T>();
-@@ -183,7 +183,7 @@
- for (uint64 i=0;i<q;i++) ret[i] = Op::func(Ap[i],Bp);
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(Tclass,Acast.dimensions());
-+ F = Array(Tclass,Acast.dimensions());
- T* Cr = F.real<T>().data();
- T* Ci = F.imag<T>().data();
- const T* Ar = Acast.constReal<T>().constData();
-@@ -197,7 +197,7 @@
- if (Acast.dimensions() != Bcast.dimensions())
- throw Exception("size mismatch in arguments to binary operator");
- if (Bcast.allReal() && Acast.allReal()) {
-- F = Array::Array(Tclass,Acast.dimensions());
-+ F = Array(Tclass,Acast.dimensions());
- T* ret = F.real<T>().data();
- const T* Ap = Acast.constReal<T>().constData();
- const T* Bp = Bcast.constReal<T>().constData();
-@@ -205,7 +205,7 @@
- for (uint64 i=0;i<q;i++) ret[i] = Op::func(Ap[i],Bp[i]);
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(Tclass,Acast.dimensions());
-+ F = Array(Tclass,Acast.dimensions());
- T* Cr = F.real<T>().data();
- T* Ci = F.imag<T>().data();
- const T* Ar = Acast.constReal<T>().constData();
-@@ -328,17 +328,17 @@
- if (!Acast.isScalar()) Acast = Acast.asDenseArray();
- if (!Bcast.isScalar()) Bcast = Bcast.asDenseArray();
- if (Acast.isScalar() && Bcast.isScalar()) {
-- F = Array::Array(Op::func(Acast.constRealScalar<T>(),
-+ F = Array(Op::func(Acast.constRealScalar<T>(),
- Bcast.constRealScalar<T>()));
- } else if (Acast.isScalar()) {
-- F = Array::Array(Bool,Bcast.dimensions());
-+ F = Array(Bool,Bcast.dimensions());
- bool* ret = F.real<bool>().data();
- const T& Ap = Acast.constRealScalar<T>();
- const T* Bp = Bcast.constReal<T>().constData();
- uint64 q = uint64(Bcast.length());
- for (uint64 i=0;i<q;i++) ret[i] = Op::func(Ap,Bp[i]);
- } else if (Bcast.isScalar()) {
-- F = Array::Array(Bool,Acast.dimensions());
-+ F = Array(Bool,Acast.dimensions());
- bool* ret = F.real<bool>().data();
- const T* Ap = Acast.constReal<T>().constData();
- const T& Bp = Bcast.constRealScalar<T>();
-@@ -347,7 +347,7 @@
- } else {
- if (Acast.dimensions() != Bcast.dimensions())
- throw Exception("size mismatch in arguments to binary operator");
-- F = Array::Array(Bool,Acast.dimensions());
-+ F = Array(Bool,Acast.dimensions());
- bool* ret = F.real<bool>().data();
- const T* Ap = Acast.constReal<T>().constData();
- const T* Bp = Bcast.constReal<T>().constData();
-@@ -395,18 +395,18 @@
- if (!Bcast.isScalar()) Bcast = Bcast.asDenseArray();
- if (Acast.isScalar() && Bcast.isScalar()) {
- if (Acast.allReal() && Bcast.allReal()) {
-- F = Array::Array(Op::func(Acast.constRealScalar<T>(),
-+ F = Array(Op::func(Acast.constRealScalar<T>(),
- Bcast.constRealScalar<T>()));
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(Op::func(Acast.constRealScalar<T>(),
-+ F = Array(Op::func(Acast.constRealScalar<T>(),
- Acast.constImagScalar<T>(),
- Bcast.constRealScalar<T>(),
- Bcast.constImagScalar<T>()));
- }
- } else if (Acast.isScalar()) {
- if (Acast.allReal() && Bcast.allReal()) {
-- F = Array::Array(Bool,Bcast.dimensions());
-+ F = Array(Bool,Bcast.dimensions());
- bool* ret = F.real<bool>().data();
- const T& Ap = Acast.constRealScalar<T>();
- const T* Bp = Bcast.constReal<T>().constData();
-@@ -414,7 +414,7 @@
- for (uint64 i=0;i<q;i++) ret[i] = Op::func(Ap,Bp[i]);
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(Bool,Bcast.dimensions());
-+ F = Array(Bool,Bcast.dimensions());
- bool* ret = F.real<bool>().data();
- const T& Ar = Acast.constRealScalar<T>();
- const T& Ai = Acast.constImagScalar<T>();
-@@ -425,7 +425,7 @@
- }
- } else if (Bcast.isScalar()) {
- if (Bcast.allReal() && Acast.allReal()) {
-- F = Array::Array(Bool,Acast.dimensions());
-+ F = Array(Bool,Acast.dimensions());
- bool* ret = F.real<bool>().data();
- const T* Ap = Acast.constReal<T>().constData();
- const T& Bp = Bcast.constRealScalar<T>();
-@@ -433,7 +433,7 @@
- for (uint64 i=0;i<q;i++) ret[i] = Op::func(Ap[i],Bp);
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(Bool,Acast.dimensions());
-+ F = Array(Bool,Acast.dimensions());
- bool* ret = F.real<bool>().data();
- const T* Ar = Acast.constReal<T>().constData();
- const T* Ai = Acast.constImag<T>().constData();
-@@ -446,7 +446,7 @@
- if (Acast.dimensions() != Bcast.dimensions())
- throw Exception("size mismatch in arguments to binary operator");
- if (Bcast.allReal() && Acast.allReal()) {
-- F = Array::Array(Bool,Acast.dimensions());
-+ F = Array(Bool,Acast.dimensions());
- bool* ret = F.real<bool>().data();
- const T* Ap = Acast.constReal<T>().constData();
- const T* Bp = Bcast.constReal<T>().constData();
-@@ -454,7 +454,7 @@
- for (uint64 i=0;i<q;i++) ret[i] = Op::func(Ap[i],Bp[i]);
- } else {
- Acast.forceComplex(); Bcast.forceComplex();
-- F = Array::Array(Bool,Acast.dimensions());
-+ F = Array(Bool,Acast.dimensions());
- bool* ret = F.real<bool>().data();
- const T* Ar = Acast.constReal<T>().constData();
- const T* Ai = Acast.constImag<T>().constData();
-@@ -533,9 +533,9 @@
- if (!Acast.isScalar()) Acast = Acast.asDenseArray();
- if (Acast.isScalar()) {
- if (Acast.allReal()) {
-- F = Array::Array(Op::func(Acast.constRealScalar<T>()));
-+ F = Array(Op::func(Acast.constRealScalar<T>()));
- } else {
-- F = Array::Array(T(0),T(0));
-+ F = Array(T(0),T(0));
- Op::func(Acast.constRealScalar<T>(),
- Acast.constImagScalar<T>(),
- F.realScalar<T>(),F.imagScalar<T>());
diff --git a/sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch b/sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch
deleted file mode 100644
index dd3798bb8f6a..000000000000
--- a/sci-mathematics/freemat/files/freemat-4.0-no_implicit_GLU.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-error: 'gluProject' was not declared in this scope
-
-http://bugs.gentoo.org/402361
-
---- libs/libGraphics/GLRenderEngine.cpp
-+++ libs/libGraphics/GLRenderEngine.cpp
-@@ -20,6 +20,7 @@
- #include <qimage.h>
- #include <qpainter.h>
- #include <QtOpenGL>
-+#include <GL/glu.h>
- #include <math.h>
- #include "IEEEFP.hpp"
-
diff --git a/sci-mathematics/freemat/files/freemat-4.1-have_fftw.patch b/sci-mathematics/freemat/files/freemat-4.1-have_fftw.patch
deleted file mode 100644
index 1415b3d716aa..000000000000
--- a/sci-mathematics/freemat/files/freemat-4.1-have_fftw.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff -rupN libs/libCore.orig/FFT.cpp libs/libCore/FFT.cpp
---- libs/libCore.orig/FFT.cpp 2011-11-27 01:27:43.856779929 +0100
-+++ libs/libCore/FFT.cpp 2012-01-30 00:14:18.682460150 +0100
-@@ -104,6 +104,7 @@ public:
- #endif
-
-
-+#if HAVE_FFTWF
- class OpVecFFT {
- WrapFFTWF fft_float;
- WrapFFTW fft_double;
-@@ -169,7 +170,9 @@ public:
- }
- }
- };
-+#endif
-
-+#if HAVE_FFTWF
- class OpVecIFFT {
- WrapFFTWF fft_float;
- WrapFFTW fft_double;
-@@ -228,6 +231,7 @@ public:
- }
- }
- };
-+#endif
-
- //!
- //@Module FFT (Inverse) Fast Fourier Transform Function
-@@ -350,6 +354,8 @@ public:
- //inputs x len dim
- //outputs y
- //!
-+
-+#if HAVE_FFTWF
- ArrayVector FFTFunction(int nargout, const ArrayVector& arg) {
- // Get the data argument
- if (arg.size() < 1)
-@@ -384,7 +390,9 @@ ArrayVector FFTFunction(int nargout, con
- OpVecFFT op(FFTLength);
- return ArrayVector(VectorOpDynamic<OpVecFFT>(arg0,FFTLength,FFTDim,op));
- }
-+#endif
-
-+#if HAVE_FFTWF
- ArrayVector IFFTFunction(int nargout, const ArrayVector& arg) {
- // Get the data argument
- if (arg.size() < 1)
-@@ -419,3 +427,4 @@ ArrayVector IFFTFunction(int nargout, co
- OpVecIFFT op(FFTLength);
- return ArrayVector(VectorOpDynamic<OpVecIFFT>(arg0,FFTLength,FFTDim,op));
- }
-+#endif
-diff -rupN libs/libCore.orig/Loader.cpp libs/libCore/Loader.cpp
---- libs/libCore.orig/Loader.cpp 2012-01-30 00:08:41.463155562 +0100
-+++ libs/libCore/Loader.cpp 2012-01-30 00:12:24.422448304 +0100
-@@ -43,8 +43,10 @@ ArrayVector FeofFunction(int, const Arra
- ArrayVector FseekFunction(int, const ArrayVector&);
- ArrayVector FgetlineFunction(int, const ArrayVector&);
- ArrayVector FscanfFunction(int, const ArrayVector&);
-+#ifdef HAVE_FFTW
- ArrayVector FFTFunction(int, const ArrayVector&);
- ArrayVector IFFTFunction(int, const ArrayVector&);
-+#endif
- ArrayVector StrCmpFunction(int, const ArrayVector&);
- ArrayVector StrCmpiFunction(int, const ArrayVector&);
- ArrayVector StrnCmpFunction(int, const ArrayVector&);
-@@ -286,8 +288,10 @@ void LoadBuiltinFunctionsCore(Context *c
- context->addFunction("fseek",FseekFunction,0,3,0,"handle","offset","style",NULL);
- context->addFunction("fgetline",FgetlineFunction,0,1,1,"handle",NULL);
- context->addFunction("fscanf",FscanfFunction,0,-1,-1,NULL);
-+#ifdef HAVE_FFTW
- context->addFunction("fft",FFTFunction,0,3,1,"x","len","dim",NULL);
- context->addFunction("ifft",IFFTFunction,0,3,1,"x","len","dim",NULL);
-+#endif
- context->addFunction("strcmp",StrCmpFunction,0,2,1,"string1","string2",NULL);
- context->addFunction("strcmpi",StrCmpiFunction,0,2,1,"string1","string2",NULL);
- context->addFunction("strncmp",StrnCmpFunction,0,3,1,"string1","string2","len",NULL);
diff --git a/sci-mathematics/freemat/files/freemat-4.1-local_libffi.patch b/sci-mathematics/freemat/files/freemat-4.1-local_libffi.patch
deleted file mode 100644
index 3fbfef9c9516..000000000000
--- a/sci-mathematics/freemat/files/freemat-4.1-local_libffi.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- CMakeLists.txt.orig 2011-11-27 01:27:11.116482600 +0100
-+++ CMakeLists.txt 2012-01-29 17:09:54.072342306 +0100
-@@ -160,8 +160,8 @@ if(MINGW)
- INCLUDE_DIRECTORIES(${FFI_INCLUDE_DIR})
- INSTALL(FILES ${FFI_LIBRARY_DLL} DESTINATION bin )
- else(MINGW)
-- FIND_LIBRARY(FFI_LIBRARY NAMES ffi DOC "Location of the FFI library" PATHS ${LOCAL_PATH})
-- FIND_PATH(FFI_INCLUDE_DIR ffi.h doc "Location of ffi.h" PATHS ${LOCAL_PATH} /usr/include/ffi /usr/lib64/libffi-3.0.9/include)
-+ FIND_LIBRARY(FFI_LIBRARY NAMES ffi DOC "Location of the FFI library" PATHS ${LOCAL_PATH} ${PROJECT_SOURCE_DIR}/dependencies/libffi/build/.libs)
-+ FIND_PATH(FFI_INCLUDE_DIR ffi.h doc "Location of ffi.h" PATHS ${LOCAL_PATH} /usr/include/ffi /usr/lib64/libffi-3.0.9/include ${PROJECT_SOURCE_DIR}/dependencies/libffi/build/include /mingw/include/ffi)
- SET(OPTIONAL_LIBS ${OPTIONAL_LIBS} ${FFI_LIBRARY})
- INCLUDE_DIRECTORIES(${FFI_INCLUDE_DIR})
- endif(MINGW)
diff --git a/sci-mathematics/freemat/files/freemat-4.1-portaudio.patch b/sci-mathematics/freemat/files/freemat-4.1-portaudio.patch
deleted file mode 100644
index 518ccfbd1334..000000000000
--- a/sci-mathematics/freemat/files/freemat-4.1-portaudio.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/thirdparty/portaudio/CMakeLists.txt.orig 2012-01-29 02:08:08.422664514 +0100
-+++ libs/thirdparty/portaudio/CMakeLists.txt 2012-01-29 02:04:26.826460722 +0100
-@@ -73,6 +73,7 @@ IF (NOT WIN32 AND NOT APPLE)
- ${CMAKE_CURRENT_SOURCE_DIR}/src/common/pa_stream.c
- ${CMAKE_CURRENT_SOURCE_DIR}/src/common/pa_trace.c
- ${CMAKE_CURRENT_SOURCE_DIR}/src/hostapi/oss/pa_unix_oss.c
-+ ${CMAKE_CURRENT_SOURCE_DIR}/src/hostapi/skeleton/pa_hostapi_skeleton.c
- ${CMAKE_CURRENT_SOURCE_DIR}/src/os/unix/pa_unix_hostapis.c
- ${CMAKE_CURRENT_SOURCE_DIR}/src/os/unix/pa_unix_util.c )
- ENDIF (NOT WIN32 AND NOT APPLE)
diff --git a/sci-mathematics/freemat/files/freemat-4.1-use_llvm.patch b/sci-mathematics/freemat/files/freemat-4.1-use_llvm.patch
deleted file mode 100644
index 327aa30f09ab..000000000000
--- a/sci-mathematics/freemat/files/freemat-4.1-use_llvm.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- libs/libMatC/CMakeLists.txt.orig 2011-11-27 01:27:43.000000000 +0100
-+++ libs/libMatC/CMakeLists.txt 2012-01-29 14:39:19.842402326 +0100
-@@ -1,10 +1,14 @@
-
- INCLUDE_DIRECTORIES( ${CMAKE_CURRENT_BINARY_DIR} ${QT_INCLUDE_DIR} ${QT_QTCORE_INCLUDE_DIR} ${QT_QTGUI_INCLUDE_DIR} )
-
-+IF( USE_LLVM )
-+ set(LLVM_SOURCES "CJitFuncClang.cpp")
-+endif( USE_LLVM )
-+
- ADD_LIBRARY( MatC
- JITFactory.cpp
- CJitFunc.cpp
-- CJitFuncClang.cpp
-+ ${LLVM_SOURCES}
- CArray.cpp
- )
-
---- libs/libMatC.orig/JITFactory.cpp 2011-11-27 01:27:43.000000000 +0100
-+++ libs/libMatC/JITFactory.cpp 2012-01-29 14:53:17.296686846 +0100
-@@ -1,5 +1,7 @@
- #include "JITFactory.hpp"
--#include "CJitFuncClang.hpp"
-+#ifdef HAVE_LLVM
-+# include "CJitFuncClang.hpp"
-+#endif
-
- JITFuncBase* JITFactory::GetJITFunc(Interpreter *eval)
- {