summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2021-04-26 18:32:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-10 09:54:01 +0300
commit33a26872e32347c0e0a4a8becf136c818d8119c6 (patch)
tree6d3088b6d999a988674ca016bd47a1a9589506c9 /sci-mathematics
parentapp-accessibility/speech-tools: removed obsolete 2.4-r1 (diff)
downloadgentoo-33a26872e32347c0e0a4a8becf136c818d8119c6.tar.gz
gentoo-33a26872e32347c0e0a4a8becf136c818d8119c6.tar.bz2
gentoo-33a26872e32347c0e0a4a8becf136c818d8119c6.zip
sci-mathematics/gimps: Version bump to 30.6 build 4
Closes: https://bugs.gentoo.org/785859 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-3.0.18, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/20550 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gimps/Manifest1
-rw-r--r--sci-mathematics/gimps/gimps-30.6.4.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 8207ef9fc70e..edcd72b8604f 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -1,3 +1,4 @@
+DIST gimps-30.6.4.linux64.tar.gz 7282669 BLAKE2B 7621ebd8f55660dcdb9f7b892c1963b3de1af72b186053386c4847fdf4ce9b2d7fc9e113bca99d9afccb9574b935ade4a66c485c97f67224def284b0a16ad601 SHA512 20268be0b94b86d62fc2b46f7add1a4353188638fcf9e647b294484bd049ddcaa046fbe284d48c3a263389366ff9edda024ef122faf33d0e78c6f20820f8cf0a
DIST p95v303b6.linux32.tar.gz 5702312 BLAKE2B 728c8b8e7e2b5187dc8126bccc5e2c165fbfbc0900d6c35517cd21b78e5292df143641e3766cc0146918062039b1eecab568f9b278f64b1b9197ee2f775603b9 SHA512 3e06fb77be07334949ece3ae152bdf5491f0b7f8e33e0e8ed2af3c34332841975a9514d1993ed2355abfa4e09f93e42093d02f96dc30c3471ae9f974cc2de11a
DIST p95v303b6.linux64.tar.gz 7046127 BLAKE2B 9cde9c2670203071cfc463434a47c8123064cb232bfeb25d8767cad2c25ea75b395e2ec135b7b4a6dc9616e9d6b05ead371e1083274a82468f62a0e1de93c98f SHA512 6d6ded9a1724993d42adee28d400b0337835c52a4ce42271e62efb37134adfc6f017f55475860fbc1224e377a227ef8547b8852a35c082c37e996f4a1c1b570c
DIST p95v305b2.linux32.tar.gz 5695951 BLAKE2B d97f5b553e0a0563d51a08049c08fe31231e2689cfe6ec979b832603bace334755e947be2d7a106d4f4b807070568746f2cdabf869c5c4c6e125155c332b10bf SHA512 b5caa642e742438f10b5ee89d27213834755051679fe0d4d452e446b2f7628c8a874227971473d4319b8841f47a0bb32e7de9731d8b45e808356efb11922716e
diff --git a/sci-mathematics/gimps/gimps-30.6.4.ebuild b/sci-mathematics/gimps/gimps-30.6.4.ebuild
new file mode 100644
index 000000000000..f1cf70e083a8
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-30.6.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux64.tar.gz -> ${P}.linux64.tar.gz )
+ "
+
+SLOT="0"
+LICENSE="GIMPS"
+RESTRICT="mirror bindist"
+KEYWORDS="-* ~amd64"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+OPTINSTALLDIR="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt undoc.txt whatsnew.txt )
+
+src_install() {
+ dodir ${OPTINSTALLDIR}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${OPTINSTALLDIR}" || die
+ fperms a-w "${OPTINSTALLDIR}/mprime"
+ fowners root:0 "${OPTINSTALLDIR}"
+ fowners root:0 "${OPTINSTALLDIR}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}