summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-30 01:19:38 +0100
committerSam James <sam@gentoo.org>2023-04-30 01:19:38 +0100
commit32bf1dfde8a72f36a664ce986076509778202f93 (patch)
treeae5f443379f9ecf03815d6a6b0c83ba8d97de3d2 /sci-mathematics
parentsys-devel/gcc: add 13.1.1_p20230429 (diff)
downloadgentoo-32bf1dfde8a72f36a664ce986076509778202f93.tar.gz
gentoo-32bf1dfde8a72f36a664ce986076509778202f93.tar.bz2
gentoo-32bf1dfde8a72f36a664ce986076509778202f93.zip
sci-mathematics/form: workaround GCC -fchecking ICE w/ -Wno-uninitialized
Reported upstream at https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109521 but let's apply a workaround for now to avoid dupes. It's "only" an error in diagnostics anyway. Closes: https://bugs.gentoo.org/904339 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/form/form-4.3.0-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-mathematics/form/form-4.3.0-r1.ebuild b/sci-mathematics/form/form-4.3.0-r1.ebuild
index abdbf0481b5f..d3d5800ac1e2 100644
--- a/sci-mathematics/form/form-4.3.0-r1.ebuild
+++ b/sci-mathematics/form/form-4.3.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools toolchain-funcs elisp-common
+inherit autotools flag-o-matic toolchain-funcs elisp-common
DESCRIPTION="Symbolic Manipulation System"
HOMEPAGE="https://www.nikhef.nl/~form/ https://github.com/vermaseren/form/"
@@ -34,6 +34,9 @@ src_prepare() {
}
src_configure() {
+ # Workaround for GCC -fchecking ICE, bug #904339
+ append-cxxflags $(test-flags-CXX -Wno-uninitialized)
+
econf \
--enable-scalar \
--enable-largefile \