summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-09-04 18:15:05 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-09-04 18:15:36 +0200
commita81812c1f82f324843c383eda80c30f495ebfe50 (patch)
treebbb7d021c25bc28593708e230c17e894434476ae /sci-libs
parentwww-apps/sonarr-bin: drop 4.0.9.2332 (diff)
downloadgentoo-a81812c1f82f324843c383eda80c30f495ebfe50.tar.gz
gentoo-a81812c1f82f324843c383eda80c30f495ebfe50.tar.bz2
gentoo-a81812c1f82f324843c383eda80c30f495ebfe50.zip
sci-libs/onnx: rdepend on abseil-cpp:=
Closes: https://bugs.gentoo.org/939018 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/Manifest1
-rw-r--r--sci-libs/onnx/onnx-1.16.1-r1.ebuild (renamed from sci-libs/onnx/onnx-1.16.0-r1.ebuild)4
-rw-r--r--sci-libs/onnx/onnx-1.16.1.ebuild71
3 files changed, 2 insertions, 74 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index 65f50bc1fcf2..5b59ba271455 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -1,2 +1 @@
-DIST onnx-1.16.0.tar.gz 12428161 BLAKE2B b0d16212c527078fcbe46af8efaf8bfccb0a22825cfee3c88728314599bc90f5b43ae407cc9ec10300ed19367dff769a5d6ba29d2faa61fd8e27029e2d64e83a SHA512 ef641447d8d6c4ed9f083793fe14a8568d6aa7b9b7e7b859a4082e9b892acd801230da2027d097ceaa0d68bbd37b2422b89bb7d1d55d5c3b5955c0f9c7c657c5
DIST onnx-1.16.1.tar.gz 12428832 BLAKE2B 15a7db2fa263914957c671bd8e94eb8b80afeba0b396e8b54f8fb2deda2965885055efae7a6f6e402eb085b5795025020f650132023ba3d4df1f395d99ec353c SHA512 0ae1b36563ddeaa9947bf452eb20b83174e4c2bc4696b61768f096c401666323343fac0f699f756da99d3c29df15a0bd78fe3fa51da15f133617d7310c5b28d4
diff --git a/sci-libs/onnx/onnx-1.16.0-r1.ebuild b/sci-libs/onnx/onnx-1.16.1-r1.ebuild
index 16f073d9b4d3..0e8227eb2487 100644
--- a/sci-libs/onnx/onnx-1.16.0-r1.ebuild
+++ b/sci-libs/onnx/onnx-1.16.1-r1.ebuild
@@ -22,9 +22,9 @@ RDEPEND="
dev-python/protobuf-python[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
dev-libs/protobuf:=
+ dev-cpp/abseil-cpp:=
"
-DEPEND="${RDEPEND}
- dev-cpp/abseil-cpp"
+DEPEND="${RDEPEND}"
src_prepare() {
eapply "${FILESDIR}"/${PN}-1.15.0-hidden.patch
diff --git a/sci-libs/onnx/onnx-1.16.1.ebuild b/sci-libs/onnx/onnx-1.16.1.ebuild
deleted file mode 100644
index 16f073d9b4d3..000000000000
--- a/sci-libs/onnx/onnx-1.16.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 cmake
-
-DESCRIPTION="Open Neural Network Exchange (ONNX)"
-HOMEPAGE="https://github.com/onnx/onnx"
-SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-IUSE="disableStaticReg"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- dev-libs/protobuf:=
-"
-DEPEND="${RDEPEND}
- dev-cpp/abseil-cpp"
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-1.15.0-hidden.patch
- cmake_src_prepare
- distutils-r1_src_prepare
-}
-
-python_configure_all()
-{
- mycmakeargs=(
- -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
- -DONNX_USE_LITE_PROTO=ON
- -DONNX_BUILD_SHARED_LIBS=ON
- -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
- )
- cmake_src_configure
-}
-
-src_configure() {
- distutils-r1_src_configure
-}
-
-src_compile() {
- mycmakeargs=(
- -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
- -DONNX_USE_LITE_PROTO=ON
- -DONNX_BUILD_SHARED_LIBS=ON
- -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
- )
- CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
-}
-
-python_compile_all() {
- cmake_src_compile
-}
-
-python_install_all() {
- cmake_src_install
- distutils-r1_python_install_all
-}
-
-src_install() {
- distutils-r1_src_install
-}