summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-12-09 21:16:34 +0300
committerPetr Vaněk <arkamar@gentoo.org>2024-12-10 09:36:28 +0100
commit3f21defa85de04854342bf76046a3ffae3a1d251 (patch)
tree5689eb77d3f16c8bc7ecf0754a753e368e939cef /sci-libs
parentnet-im/discord: add 0.0.77, drop 0.0.76 (diff)
downloadgentoo-3f21defa85de04854342bf76046a3ffae3a1d251.tar.gz
gentoo-3f21defa85de04854342bf76046a3ffae3a1d251.tar.bz2
gentoo-3f21defa85de04854342bf76046a3ffae3a1d251.zip
sci-libs/cantera: drop old 3.0.0-r1
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cantera/Manifest1
-rw-r--r--sci-libs/cantera/cantera-3.0.0-r1.ebuild148
2 files changed, 0 insertions, 149 deletions
diff --git a/sci-libs/cantera/Manifest b/sci-libs/cantera/Manifest
index 0e7764e95f41..b36e38ff4cea 100644
--- a/sci-libs/cantera/Manifest
+++ b/sci-libs/cantera/Manifest
@@ -1,2 +1 @@
-DIST cantera-3.0.0.tar.gz 2451103 BLAKE2B 094d7a4f0b8fd0f1a45d9f8c13e1390cf7fc62110e424e1287030e97382c1cdc016a5119adc4d5c7bbc222420a3b447db93fee8350643cb3a0907a838fbc1ddf SHA512 dffd696628210ae5c7b08e394e9a97262cfa6aa07ac2e6faa48591ecfee5bb11e7c2b6928563007fd581a1fd9cae999f7c1414ab5d5a312a823e155573df7aca
DIST cantera-3.0.1.tar.gz 2451841 BLAKE2B b05771021a81d5266dfed382e2a6357e5b70653c6d9cfb5f03a6755095f4f8f4e7c0f78b79e0bf131c01fefce46bbc647c790ee412b6457c515cda39d4fc3054 SHA512 fa993b33867c6c0a0ca539f52116c4cdea739dfcd30deb5d2f66042f290f7f2f60112d7a37c38fbd8a38a119e5af00a7a85fd80b6e36388202b666be0ddd7715
diff --git a/sci-libs/cantera/cantera-3.0.0-r1.ebuild b/sci-libs/cantera/cantera-3.0.0-r1.ebuild
deleted file mode 100644
index c6b3ec2711e1..000000000000
--- a/sci-libs/cantera/cantera-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD="77 90"
-
-inherit flag-o-matic fortran-2 python-single-r1 scons-utils toolchain-funcs
-
-DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
-HOMEPAGE="https://www.cantera.org"
-SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="fortran hdf5 lapack +python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-cpp/yaml-cpp
- hdf5? ( sci-libs/HighFive )
- !lapack? ( sci-libs/sundials:0= )
- lapack? (
- >=sci-libs/sundials-6.5.0:0=[lapack?]
- virtual/lapack
- )
- python? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- ')
- )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/eigen:3
- dev-libs/boost:=
- dev-libs/libfmt
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- ')
- )
- test? (
- >=dev-cpp/gtest-1.11.0
- python? (
- $(python_gen_cond_dep '
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- ')
- )
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}_env.patch"
- "${FILESDIR}/${P}_enable_python-3.12.patch"
-)
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-## Full list of configuration options of Cantera is presented here:
-## http://cantera.org/docs/sphinx/html/compiling/config-options.html
-src_configure() {
- # -Werror=odr, -Werror=lto-type-mismatch
- # https://github.com/Cantera/cantera/issues/1783
- filter-lto
-
- scons_vars=(
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- cc_flags="${CXXFLAGS}"
- cxx_flags="-std=c++17"
- debug="no"
- FORTRAN="$(tc-getFC)"
- FORTRANFLAGS="${FCFLAGS}"
- optimize_flags="-Wno-inline"
- renamed_shared_libraries="no"
- use_pch="no"
- ## In some cases other order can break the detection of right location of Boost: ##
- system_fmt="y"
- system_sundials="y"
- system_eigen="y"
- system_yamlcpp="y"
- hdf_support=$(usex hdf5 y n)
- system_blas_lapack=$(usex lapack y n)
- env_vars="all"
- extra_inc_dirs="/usr/include/eigen3"
- use_rpath_linkage="yes"
- extra_lib_dirs="/usr/$(get_libdir)/${PN}"
- )
- use hdf5 && scons_vars+=( system_highfive="y" )
- use lapack && scons_vars+=( blas_lapack_libs="lapack,blas" )
- use test || scons_vars+=( googletest="none" )
-
- scons_targets=(
- f90_interface=$(usex fortran y n)
- )
-
- if use python ; then
- scons_targets+=( python_package="full" python_cmd="${EPYTHON}" )
- else
- scons_targets+=( python_package="none" )
- fi
-}
-
-src_compile() {
- escons build "${scons_vars[@]}" "${scons_targets[@]}" prefix="/usr"
-}
-
-src_test() {
- escons test
-}
-
-src_install() {
- escons install stage_dir="${D}" libdirname="$(get_libdir)"
- if ! use python ; then
- rm -r "${D}/usr/share/man" || die "Can't remove man files."
- else
- # Run the byte-compile of modules
- python_optimize "${D}$(python_get_sitedir)/${PN}"
- fi
-
- # User could remove this line if require static libs for development purpose
- find "${ED}" -name '*.a' -delete || die
-}
-
-pkg_postinst() {
- local post_msg=$(usex fortran "and Fortran " "")
- elog "C++ ${post_msg}samples are installed to '/usr/share/${PN}/samples/' directory."
-}