summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 18:50:26 +0000
committerSam James <sam@gentoo.org>2022-03-20 18:51:28 +0000
commit01be6b457af58e5994e6c0a2d723e98d89a43e6d (patch)
tree6768b36861c769445d2d40f76a0f08421974e3ce /sci-libs/superlu_mt
parentsci-libs/profphd-utils: [QA] fix tc-get* quoting (diff)
downloadgentoo-01be6b457af58e5994e6c0a2d723e98d89a43e6d.tar.gz
gentoo-01be6b457af58e5994e6c0a2d723e98d89a43e6d.tar.bz2
gentoo-01be6b457af58e5994e6c0a2d723e98d89a43e6d.zip
sci-libs/superlu_mt: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/superlu_mt')
-rw-r--r--sci-libs/superlu_mt/superlu_mt-3.1-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/superlu_mt/superlu_mt-3.1-r1.ebuild b/sci-libs/superlu_mt/superlu_mt-3.1-r1.ebuild
index 631f199b5ca3..ec84973ee7d0 100644
--- a/sci-libs/superlu_mt/superlu_mt-3.1-r1.ebuild
+++ b/sci-libs/superlu_mt/superlu_mt-3.1-r1.ebuild
@@ -33,12 +33,12 @@ PATCHES=(
pkg_setup() {
if use openmp && ! use threads; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ if [[ "$(tc-getCC)" == *gcc ]] && ! tc-has-openmp; then
ewarn "OpenMP is not available in your current selected gcc"
die "need openmp capable gcc"
fi
CTHREADS="-D__OPENMP"
- [[ $(tc-getCC) == *gcc ]] && LDTHREADS="-fopenmp"
+ [[ "$(tc-getCC)" == *gcc ]] && LDTHREADS="-fopenmp"
else
CTHREADS="-D__PTHREAD"
LDTHREADS="-pthread"