summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-06-06 08:57:04 +1200
committerMichael Orlitzky <mjo@gentoo.org>2023-06-19 20:01:05 -0400
commita968922ef8291a098c291cbeeab9effd178eab20 (patch)
treeaa836d123a181dfc6dd7c1dd2d8eeb55512a27cf /sci-libs/suitesparseconfig
parentsci-libs/p4est: also install cmake configuration (diff)
downloadgentoo-a968922ef8291a098c291cbeeab9effd178eab20.tar.gz
gentoo-a968922ef8291a098c291cbeeab9effd178eab20.tar.bz2
gentoo-a968922ef8291a098c291cbeeab9effd178eab20.zip
sci-libs/suitesparseconfig: add 7.0.0
Signed-off-by: François Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/suitesparseconfig')
-rw-r--r--sci-libs/suitesparseconfig/Manifest1
-rw-r--r--sci-libs/suitesparseconfig/metadata.xml3
-rw-r--r--sci-libs/suitesparseconfig/suitesparseconfig-7.0.0.ebuild39
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/suitesparseconfig/Manifest b/sci-libs/suitesparseconfig/Manifest
index 7474afad0356..23d23ac03bc7 100644
--- a/sci-libs/suitesparseconfig/Manifest
+++ b/sci-libs/suitesparseconfig/Manifest
@@ -1 +1,2 @@
+DIST SuiteSparse-7.0.0.gh.tar.gz 64884962 BLAKE2B 06c6cf54ffae188f5179e0cd45523700448d8999b44d6b1aeb3dfb99ccf34a570f6aff600988a144c68a4a2d8f41e32f7145e09349aed3bd889501ea031c8340 SHA512 50b1cd7bab6e4c063984162ed803fd13b69df7f67efe8ce7af15eace6b0ccd1669b6e57daa59511fd9531a847433cda49c1f52bfff234031af0d79e7fbd6423e
DIST suitesparseconfig-5.4.0.tar.bz2 257352 BLAKE2B 3832e34281c742a7d704dde866c53c742420486d782075e047b605fb2062d77353cda8670138c4bef62c73d16e123a8a74f65272a01766f124c1e53f9ba32e9d SHA512 e91f60f426b73add473c6341e30512b8fbe65b7850cd83f3852e78f1e74ce067b7ae1577ccc795698e680a841a9d32c2ca073651a4fe95f0b723578721aec874
diff --git a/sci-libs/suitesparseconfig/metadata.xml b/sci-libs/suitesparseconfig/metadata.xml
index 58f40fb53a98..c79fd37845bc 100644
--- a/sci-libs/suitesparseconfig/metadata.xml
+++ b/sci-libs/suitesparseconfig/metadata.xml
@@ -9,4 +9,7 @@
SuiteSparse_config is a set of configuration files for the SuiteSparse matrix libraries
from CISE at University of Florida. It contains some headers and makefiles.
</longdescription>
+ <upstream>
+ <remote-id type="github">DrTimothyAldenDavis/SuiteSparse</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-libs/suitesparseconfig/suitesparseconfig-7.0.0.ebuild b/sci-libs/suitesparseconfig/suitesparseconfig-7.0.0.ebuild
new file mode 100644
index 000000000000..af3881fdabdb
--- /dev/null
+++ b/sci-libs/suitesparseconfig/suitesparseconfig-7.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib toolchain-funcs
+
+Sparse_PV=$(ver_rs 3 '.')
+Sparse_P="SuiteSparse-${Sparse_PV}"
+DESCRIPTION="Common configurations for all packages in suitesparse"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="openmp"
+
+S="${WORKDIR}/${Sparse_P}/SuiteSparse_config"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+multilib_src_configure() {
+ # Make sure we always include the Fortran interface.
+ # It doesn't require a Fortran compiler to be present
+ # and simplifies the configuration for dependencies.
+ local mycmakeargs=(
+ -DNSTATIC=ON
+ -DNFORTRAN=OFF
+ -DNOPENMP=$(usex openmp OFF ON)
+ )
+ cmake_src_configure
+}