summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/orocos-bfl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/orocos-bfl')
-rw-r--r--sci-libs/orocos-bfl/Manifest1
-rw-r--r--sci-libs/orocos-bfl/metadata.xml14
-rw-r--r--sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild63
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-libs/orocos-bfl/Manifest b/sci-libs/orocos-bfl/Manifest
new file mode 100644
index 000000000000..eede2eae1d91
--- /dev/null
+++ b/sci-libs/orocos-bfl/Manifest
@@ -0,0 +1 @@
+DIST orocos-bfl-0.8.0-src.tar.bz2 212899 SHA256 e5e14f8abbc4c38ca51f5ff97b36f66c69da3a706ee6276bcb151ada4c71195c SHA512 045bbc415feec66206774a8bdea3843a7edf233d221bd639b1dcc01906386ff55f114a9685e1008b741ae895e6aef33641a1eab67cb106d23a085d77f1a937d5 WHIRLPOOL ba5ff1ad0ff25cbc45367ed3d0bc1f356ef827f1b0ef6fa3e4c26a0a0da7ef8efc44bb6b0b1a33cbc068f28d079d0f9e096b14efd5df0d54d5dafe80e95c0fec
diff --git a/sci-libs/orocos-bfl/metadata.xml b/sci-libs/orocos-bfl/metadata.xml
new file mode 100644
index 000000000000..b187a8cfc9fa
--- /dev/null
+++ b/sci-libs/orocos-bfl/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+<longdescription lang="en">
+ The Bayesian Filtering Library (BFL) provides an application independent framework
+ for inference in Dynamic Bayesian Networks, i.e., recursive information processing
+ and estimation algorithms based on Bayes' rule, such as (Extended) Kalman Filters,
+ Particle Filters (or Sequential Monte Carlo methods), etc.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild b/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild
new file mode 100644
index 000000000000..d326f65c46db
--- /dev/null
+++ b/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Bayesian Filtering Library"
+HOMEPAGE="http://orocos.org/bfl"
+SRC_URI="http://people.mech.kuleuven.be/~tdelaet/bfl_tar/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ )
+ test? ( dev-util/cppunit )"
+
+src_prepare() {
+ sed -e 's:/lib:/${CMAKE_INSTALL_LIBDIR}:' \
+ -i "${S}/"{,src/,src/bindings/rtt/}CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLIBRARY_TYPE=$(usex static-libs both shared)"
+ "-DBUILD_EXAMPLES=$(usex examples ON OFF)"
+ "-DBUILD_TESTS=$(usex test ON OFF)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${BUILD_DIR}"
+ doxygen || die
+ cd "${S}/docs" || die
+ pdflatex getting_started_guide || die
+ pdflatex getting_started_guide || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc ; then
+ dohtml -r "${BUILD_DIR}/doc/html/"
+ dodoc "${S}/docs/getting_started_guide.pdf"
+ fi
+}