summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-06 21:53:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-06 22:09:38 +0200
commitb7ea809f76f0505df21958345793aa13495533f3 (patch)
treee77a7ace809d1ea63f3ad25113cfbbe1a12f239f /sci-libs/libnova
parentapp-emacs/distel: re-add required erlang dependency (diff)
downloadgentoo-b7ea809f76f0505df21958345793aa13495533f3.tar.gz
gentoo-b7ea809f76f0505df21958345793aa13495533f3.tar.bz2
gentoo-b7ea809f76f0505df21958345793aa13495533f3.zip
sci-libs/libnova: update EAPI 7 -> 8, fix build w/ GCC-14
Closes: https://bugs.gentoo.org/886455 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/libnova')
-rw-r--r--sci-libs/libnova/files/libnova-0.16.0-cflags.patch23
-rw-r--r--sci-libs/libnova/files/libnova-0.16.0-gcc14.patch24
-rw-r--r--sci-libs/libnova/libnova-0.16.0.ebuild12
3 files changed, 53 insertions, 6 deletions
diff --git a/sci-libs/libnova/files/libnova-0.16.0-cflags.patch b/sci-libs/libnova/files/libnova-0.16.0-cflags.patch
new file mode 100644
index 000000000000..fcb06a9360c9
--- /dev/null
+++ b/sci-libs/libnova/files/libnova-0.16.0-cflags.patch
@@ -0,0 +1,23 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-AM_CFLAGS = -Wall -O3 $(AVX_CFLAGS)
++AM_CFLAGS = $(AVX_CFLAGS)
+
+ SUBDIRS = libnova elp
+
+--- a/src/elp/Makefile.am
++++ b/src/elp/Makefile.am
+@@ -1,6 +1,6 @@
+ noinst_LTLIBRARIES = libelp.la
+
+-AM_CFLAGS = -I ../ -Wall -O3 $(AVX_CFLAGS)
++AM_CFLAGS = -I ../ $(AVX_CFLAGS)
+
+ libelp_la_SOURCES = \
+ elp1.c \
+--
+2.45.2
+
diff --git a/sci-libs/libnova/files/libnova-0.16.0-gcc14.patch b/sci-libs/libnova/files/libnova-0.16.0-gcc14.patch
new file mode 100644
index 000000000000..330952d058bf
--- /dev/null
+++ b/sci-libs/libnova/files/libnova-0.16.0-gcc14.patch
@@ -0,0 +1,24 @@
+From 1be82238860bba941b1b16c6f31763577a17b8af Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 6 Aug 2024 21:49:52 +0200
+Subject: Fix build with >=GCC-14
+
+---
+ src/parallax.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/parallax.c b/src/parallax.c
+index 733e26c..0c11f04 100644
+--- a/src/parallax.c
++++ b/src/parallax.c
+@@ -17,6 +17,7 @@
+ */
+
+ #include <math.h>
++#include <libnova/earth.h>
+ #include <libnova/parallax.h>
+ #include <libnova/utility.h>
+ #include <libnova/sidereal_time.h>
+--
+2.45.2
+
diff --git a/sci-libs/libnova/libnova-0.16.0.ebuild b/sci-libs/libnova/libnova-0.16.0.ebuild
index bc3ef11b3d3a..c590ea70af79 100644
--- a/sci-libs/libnova/libnova-0.16.0.ebuild
+++ b/sci-libs/libnova/libnova-0.16.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -16,17 +16,17 @@ IUSE="doc examples"
BDEPEND="doc? ( app-text/doxygen )"
-PATCHES=( "${FILESDIR}"/${P}-slibtool.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-slibtool.patch
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-gcc14.patch # bug 886455
+)
src_prepare() {
default
eautoreconf
}
-src_configure() {
- econf --disable-static
-}
-
src_compile() {
default
use doc && emake -C doc doc