summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-07-20 17:18:02 +0000
committerSam James <sam@gentoo.org>2024-09-09 19:15:14 +0100
commitd9cf465d946aad98b1e7a5efd4d2fc3db72b1be0 (patch)
tree91e5d887601c1dff0bc0789fc5f284954f384135 /sci-libs/hipCUB
parentsci-libs/hipBLASLt: strip unsupported flags for potentially switched compiler (diff)
downloadgentoo-d9cf465d946aad98b1e7a5efd4d2fc3db72b1be0.tar.gz
gentoo-d9cf465d946aad98b1e7a5efd4d2fc3db72b1be0.tar.bz2
gentoo-d9cf465d946aad98b1e7a5efd4d2fc3db72b1be0.zip
sci-libs/hipCUB: strip unsupported flags for potentially switched compiler
Bug: https://bugs.gentoo.org/936099 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/hipCUB')
-rw-r--r--sci-libs/hipCUB/hipCUB-6.1.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/hipCUB/hipCUB-6.1.1.ebuild b/sci-libs/hipCUB/hipCUB-6.1.1.ebuild
index 8a38588c8d4c..ab990f284e87 100644
--- a/sci-libs/hipCUB/hipCUB-6.1.1.ebuild
+++ b/sci-libs/hipCUB/hipCUB-6.1.1.ebuild
@@ -37,6 +37,8 @@ src_prepare() {
}
src_configure() {
+ rocm_use_hipcc
+
local mycmakeargs=(
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
-DBUILD_TEST=$(usex test ON OFF)
@@ -44,7 +46,7 @@ src_configure() {
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
)
- CXX=hipcc cmake_src_configure
+ cmake_src_configure
}
src_test() {