summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-06-14 12:17:36 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-06-14 12:17:36 +0200
commit4f59fffef1fd0000a27203f4dc0ef76fce712997 (patch)
tree93d5ffd9b70bc918169f1af84b397eaaea2ad8d6 /sci-libs/foxi/files
parentdev-libs/libksba: arm64 stable wrt bug #849068 (diff)
downloadgentoo-4f59fffef1fd0000a27203f4dc0ef76fce712997.tar.gz
gentoo-4f59fffef1fd0000a27203f4dc0ef76fce712997.tar.bz2
gentoo-4f59fffef1fd0000a27203f4dc0ef76fce712997.zip
sci-libs/foxi: add to tree
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/foxi/files')
-rw-r--r--sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch b/sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch
new file mode 100644
index 000000000000..f252ae4fcdb2
--- /dev/null
+++ b/sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch
@@ -0,0 +1,73 @@
+--- a/CMakeLists.txt 2022-06-13 21:42:28.197087591 +0200
++++ b/CMakeLists.txt 2022-06-13 21:44:49.787170054 +0200
+@@ -77,6 +77,7 @@
+ OUTPUT_NAME "foxi"
+ POSITION_INDEPENDENT_CODE YES)
+ target_link_libraries(foxi_wrapper PRIVATE foxi_loader foxi)
++ target_link_options(foxi_wrapper PUBLIC "-Wl,-soname=libfoxi.so")
+ if(DEFINED FOXI_SEARCH_DIR)
+ target_compile_definitions(foxi_wrapper PRIVATE "FOXI_SEARCH_DIR=\"${FOXI_SEARCH_DIR}\"")
+ endif()
+@@ -115,11 +116,11 @@
+
+ install(TARGETS
+ foxi foxi_dummy foxi_loader
+- EXPORT ONNXTargets DESTINATION lib)
++ EXPORT ONNXTargets DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ if(NOT ANDROID AND NOT IOS)
+ install(TARGETS foxi_wrapper
+- EXPORT ONNXTargets DESTINATION lib)
++ EXPORT ONNXTargets DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
+
+ set(FOXI_INCLUDE_DIRS "${FOXI_ROOT}" "${CMAKE_CURRENT_BINARY_DIR}")
+--- a/foxi/onnxifi_wrapper.c 2022-06-14 08:07:07.351585673 +0200
++++ b/foxi/onnxifi_wrapper.c 2022-06-14 08:11:21.680855591 +0200
+@@ -761,7 +761,9 @@
+ const void* onnxModel,
+ uint32_t weightsCount,
+ const onnxTensorDescriptorV1* weightDescriptors,
+- onnxGraph* graph)
++ onnxGraph* graph,
++ uint32_t maxSeqLength,
++ void* deferredWeightReader)
+ {
+ if (graph == NULL) {
+ return ONNXIFI_STATUS_INVALID_POINTER;
+@@ -797,7 +799,9 @@
+ onnxModel,
+ weightsCount,
+ weightDescriptors,
+- &graph_wrapper->graph);
++ &graph_wrapper->graph,
++ maxSeqLength,
++ deferredWeightReader);
+ switch (status) {
+ case ONNXIFI_STATUS_SUCCESS:
+ case ONNXIFI_STATUS_FALLBACK:
+--- a/foxi/onnxifi_dummy.c 2022-06-14 08:14:02.484503254 +0200
++++ b/foxi/onnxifi_dummy.c 2022-06-14 08:17:01.408891030 +0200
+@@ -103,7 +103,9 @@
+ const void* onnxModel,
+ uint32_t weightCount,
+ const onnxTensorDescriptorV1* weightDescriptors,
+- onnxGraph* graph) {
++ onnxGraph* graph,
++ uint32_t maxSeqLength,
++ void* deferredWeightReader) {
+ if (graph == NULL) {
+ return ONNXIFI_STATUS_INVALID_POINTER;
+ }
+@@ -215,6 +217,8 @@
+ onnxWaitEventFor(onnxEvent event,
+ uint32_t timeoutMs,
+ onnxEventState* eventState,
+- onnxStatus* eventStatus) {
++ onnxStatus* eventStatus,
++ char* message,
++ size_t* messageLength) {
+ return ONNXIFI_STATUS_SUCCESS;
+-}
+\ No newline at end of file
++}