summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKalin KOZHUHAROV <me.kalin@gmail.com>2018-04-22 21:23:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-23 01:11:06 +0200
commit3fc25a22193c3dc265c9dde733bd50d65dab29a9 (patch)
tree1ec6737b2edcf1b2fd53ea340bd743d6171209ed /sci-geosciences
parentsci-geosciences/qgis: 3.0.2 version bump (diff)
downloadgentoo-3fc25a22193c3dc265c9dde733bd50d65dab29a9.tar.gz
gentoo-3fc25a22193c3dc265c9dde733bd50d65dab29a9.tar.bz2
gentoo-3fc25a22193c3dc265c9dde733bd50d65dab29a9.zip
sci-geosciences/qgis: Fix USE=-python building
Closes: https://bugs.gentoo.org/653712 Closes: https://github.com/gentoo/gentoo/pull/8102
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/qgis-3.0.2.ebuild11
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild11
2 files changed, 14 insertions, 8 deletions
diff --git a/sci-geosciences/qgis/qgis-3.0.2.ebuild b/sci-geosciences/qgis/qgis-3.0.2.ebuild
index cc3eaaa70558..9c686b0dc1a5 100644
--- a/sci-geosciences/qgis/qgis-3.0.2.ebuild
+++ b/sci-geosciences/qgis/qgis-3.0.2.ebuild
@@ -26,6 +26,7 @@ SLOT="0"
IUSE="3d examples georeferencer grass mapserver oracle polar postgres python webkit"
REQUIRED_USE="
+ grass? ( python )
mapserver? ( python )
python? ( ${PYTHON_REQUIRED_USE} )"
@@ -104,7 +105,7 @@ PATCHES=(
)
pkg_setup() {
- python-single-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
@@ -185,10 +186,12 @@ src_install() {
docompress -x /usr/share/doc/${PF}/examples
fi
- python_optimize "${ED%/}"/usr/share/qgis/python
+ if use python; then
+ python_optimize "${ED%/}"/usr/share/qgis/python
- if use grass; then
- python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
+ if use grass; then
+ python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
+ fi
fi
}
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index cc3eaaa70558..9c686b0dc1a5 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -26,6 +26,7 @@ SLOT="0"
IUSE="3d examples georeferencer grass mapserver oracle polar postgres python webkit"
REQUIRED_USE="
+ grass? ( python )
mapserver? ( python )
python? ( ${PYTHON_REQUIRED_USE} )"
@@ -104,7 +105,7 @@ PATCHES=(
)
pkg_setup() {
- python-single-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
@@ -185,10 +186,12 @@ src_install() {
docompress -x /usr/share/doc/${PF}/examples
fi
- python_optimize "${ED%/}"/usr/share/qgis/python
+ if use python; then
+ python_optimize "${ED%/}"/usr/share/qgis/python
- if use grass; then
- python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
+ if use grass; then
+ python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
+ fi
fi
}