summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gmt/gmt-4.5.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gmt/gmt-4.5.6.ebuild')
-rw-r--r--sci-geosciences/gmt/gmt-4.5.6.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/sci-geosciences/gmt/gmt-4.5.6.ebuild b/sci-geosciences/gmt/gmt-4.5.6.ebuild
new file mode 100644
index 000000000000..821b040c3c4a
--- /dev/null
+++ b/sci-geosciences/gmt/gmt-4.5.6.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib autotools eutils
+
+GSHHS="GSHHS2.1.1"
+
+DESCRIPTION="Powerful map generator"
+HOMEPAGE="http://gmt.soest.hawaii.edu/"
+SRC_URI="mirror://gmt/GMT${PV}_src.tar.bz2
+ mirror://gmt/GMT${PV}_share.tar.bz2
+ mirror://gmt/${GSHHS}_coast.tar.bz2
+ mirror://gmt/GMT${PV}_suppl.tar.bz2
+ doc? ( mirror://gmt/GMT${PV}_doc.tar.bz2 )
+ gmtfull? ( mirror://gmt/${GSHHS}_full.tar.bz2 )
+ gmthigh? ( mirror://gmt/${GSHHS}_high.tar.bz2 )
+ gmttria? ( mirror://gmt/GMT${PV}_triangle.tar.bz2 )"
+
+LICENSE="GPL-2 gmttria? ( Artistic )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc debug gmtfull gmthigh gmttria +metric mex +netcdf octave postscript"
+
+RDEPEND="
+ !sci-biology/probcons
+ netcdf? ( >=sci-libs/netcdf-4.1 )
+ octave? ( sci-mathematics/octave )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror" # for the gmttria
+
+S="${WORKDIR}/GMT${PV}"
+
+# mex can use matlab too which i can't test
+REQUIRED_USE="
+ mex? ( octave )
+ gmthigh? ( !gmtfull ) gmtfull? ( !gmthigh )
+"
+
+# hand written make files that are not parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ mv -f "${WORKDIR}/share/"* "${S}/share/" || die
+
+ epatch \
+ "${FILESDIR}/${PN}-4.5.0-no-strip.patch" \
+ "${FILESDIR}/${PN}-4.5.6-respect-ldflags.patch" \
+ "${FILESDIR}"/${PN}-4.5.9-unistd.h.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ # triangle disabled due to non-comercial license
+ econf \
+ --libdir=/usr/$(get_libdir)/${P} \
+ --includedir=/usr/include/${P} \
+ --datadir=/usr/share/${P} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-update \
+ --disable-debug \
+ --disable-gdal \
+ --disable-matlab \
+ --disable-xgrid \
+ --enable-shared \
+ $(use_enable netcdf) \
+ $(use_enable octave) \
+ $(use_enable debug devdebug) \
+ $(use_enable !metric US) \
+ $(use_enable postscript eps) \
+ $(use_enable mex) \
+ $(use_enable gmttria triangle)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ install-gmt install-data install-suppl install-man
+
+ # remove static libs
+ find "${D}/usr/$(get_libdir)" -name '*.a' -exec rm -f {} +
+
+ dodoc README
+ use doc && dodoc -r "${S}"/share/doc/${PN}/*
+
+ cat << _EOF_ > "${T}/99gmt"
+GMTHOME=${EPREFIX}/usr/share/${P}
+GMT_SHAREDIR=${EPREFIX}/usr/share/${P}
+_EOF_
+ doenvd "${T}/99gmt"
+}