summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-10 01:28:07 +0100
committerSam James <sam@gentoo.org>2022-09-10 01:28:07 +0100
commitf1347fa55db29ab0380a12faeadd37a6788a93e3 (patch)
treeba4409dc6d57882955e1e2034d41a540991bb7ef /sci-electronics/librepcb/librepcb-0.1.6-r1.ebuild
parentsci-electronics/fritzing: revbump for quazip USE-dep change (diff)
downloadgentoo-f1347fa55db29ab0380a12faeadd37a6788a93e3.tar.gz
gentoo-f1347fa55db29ab0380a12faeadd37a6788a93e3.tar.bz2
gentoo-f1347fa55db29ab0380a12faeadd37a6788a93e3.zip
sci-electronics/librepcb: revbump for quazip USE-dep change
Fixes: e1fd8f584a15b34fa8c598655b680e69bfcb1ce4 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics/librepcb/librepcb-0.1.6-r1.ebuild')
-rw-r--r--sci-electronics/librepcb/librepcb-0.1.6-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-electronics/librepcb/librepcb-0.1.6-r1.ebuild b/sci-electronics/librepcb/librepcb-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..ff7207a0da95
--- /dev/null
+++ b/sci-electronics/librepcb/librepcb-0.1.6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2009-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake virtualx xdg
+
+DESCRIPTION="Free EDA software to develop printed circuit boards"
+HOMEPAGE="https://librepcb.org/"
+SRC_URI="https://download.librepcb.org/releases/${PV}/${P}-source.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-arch/unzip
+ dev-qt/linguist-tools:5"
+
+RDEPEND="
+ dev-cpp/muParser:=
+ dev-libs/quazip:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5"
+
+PATCHES=( "${FILESDIR}"/${P}-muparser-fix.patch )
+
+src_configure() {
+ local mycmakeargs+=(
+ -DUNBUNDLE_QUAZIP=ON
+ -DUNBUNDLE_MUPARSER=ON )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/tests/unittests || die
+ virtx ./librepcb-unittests --gtest_filter=-SystemInfoTest.testGetUsername
+}