summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/fritzing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/fritzing')
-rw-r--r--sci-electronics/fritzing/Manifest2
-rw-r--r--sci-electronics/fritzing/fritzing-0.8.7b.ebuild57
-rw-r--r--sci-electronics/fritzing/fritzing-0.9.2b.ebuild61
-rw-r--r--sci-electronics/fritzing/metadata.xml16
4 files changed, 136 insertions, 0 deletions
diff --git a/sci-electronics/fritzing/Manifest b/sci-electronics/fritzing/Manifest
new file mode 100644
index 000000000000..a37247aeea36
--- /dev/null
+++ b/sci-electronics/fritzing/Manifest
@@ -0,0 +1,2 @@
+DIST fritzing-0.8.7b.source.tar.bz2 20007914 SHA256 7d74418863a9e3b3a4eed171b8023ddea426125f08dc83ed4c55a05d39948eb4 SHA512 f45b2d4c62227ae7bf10a481775542ce5eba1ed3d9ea45e16b60517113e2af2762a8cf1155240c7242dc79886b693319e335891fa633aa41e4699ab916a7f9e9 WHIRLPOOL 385979f6edbcb5816e5c5e0872cf74e1bdd54885af4779fdbfd29e60ed8b3349265375a74968c3bae2827e5b28897b05f3f7f36a48f8f709cc0e85a2987ded16
+DIST fritzing-0.9.2b.tar.gz 10913985 SHA256 6e9dbb94a4ca5e23effc2056f471c78913b9efa4c154ced94de8f72bfe29735f SHA512 a8b6d99c4e08f86d7a7cc6574053e8b1af565a3919cb2fc406e67972052b3fa3ded002be43e4fd0345189e4e1f3cecb3851cd14711efd83ccbcbef4cbd135c58 WHIRLPOOL 70a3e310ee8f1e53e63ca7a56b9f93808e5576b8ce0995cca470a787840e5cebad7e2b357148773610971dc2db777d581a9e62bbf94fedfbd104960bab9436f6
diff --git a/sci-electronics/fritzing/fritzing-0.8.7b.ebuild b/sci-electronics/fritzing/fritzing-0.8.7b.ebuild
new file mode 100644
index 000000000000..911c1b6053a0
--- /dev/null
+++ b/sci-electronics/fritzing/fritzing-0.8.7b.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Electronic Design Automation"
+HOMEPAGE="http://fritzing.org/"
+SRC_URI="http://fritzing.org/download/${PV}/source-tarball/${P}.source.tar.bz2"
+
+LICENSE="CC-BY-SA-3.0 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtsql:4[sqlite]
+ dev-libs/quazip"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.40"
+
+S="${WORKDIR}/${P}.source"
+
+src_prepare() {
+ local translations=
+
+ qt4-r2_src_prepare
+
+ # Get a rid of the bundled libs
+ # Bug 412555 and
+ # https://code.google.com/p/fritzing/issues/detail?id=1898
+ rm -rf src/lib/quazip/ pri/quazip.pri src/lib/boost*
+
+ # Fritzing doesn't need zlib
+ sed -i -e 's:LIBS += -lz::' -e 's:-lminizip::' phoenix.pro || die
+
+ edos2unix ${PN}.desktop
+
+ # Somewhat evil but IMHO the best solution
+ for lang in $LINGUAS; do
+ lang=${lang/linguas_}
+ [ -f "translations/${PN}_${lang}.qm" ] && translations+=" translations/${PN}_${lang}.qm"
+ done
+ if [ -n "${translations}" ]; then
+ sed -i -e "s:\(translations.extra =\) .*:\1 cp -p ${translations} \$(INSTALL_ROOT)\$\$PKGDATADIR/translations\r:" phoenix.pro || die
+ else
+ sed -i -e "s:translations.extra = .*:\r:" phoenix.pro || die
+ fi
+}
+
+src_configure() {
+ eqmake4 DEFINES=QUAZIP_INSTALLED phoenix.pro
+}
diff --git a/sci-electronics/fritzing/fritzing-0.9.2b.ebuild b/sci-electronics/fritzing/fritzing-0.9.2b.ebuild
new file mode 100644
index 000000000000..52256e3b3c0c
--- /dev/null
+++ b/sci-electronics/fritzing/fritzing-0.9.2b.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="Electronic Design Automation"
+HOMEPAGE="http://fritzing.org/"
+SRC_URI="https://github.com/fritzing/fritzing-app/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtserialport:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-libs/quazip"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.40"
+
+S="${WORKDIR}/${PN}-app-${PV}"
+
+src_prepare() {
+ local translations=
+
+ # Get a rid of the bundled libs
+ # Bug 412555 and
+ # https://code.google.com/p/fritzing/issues/detail?id=1898
+ rm -rf src/lib/quazip/ pri/quazip.pri src/lib/boost*
+
+ # Fritzing doesn't need zlib
+ sed -i -e 's:LIBS += -lz::' -e 's:-lminizip::' phoenix.pro || die
+
+ edos2unix ${PN}.desktop
+
+ # Somewhat evil but IMHO the best solution
+ for lang in $LINGUAS; do
+ lang=${lang/linguas_}
+ [ -f "translations/${PN}_${lang}.qm" ] && translations+=" translations/${PN}_${lang}.qm"
+ done
+ if [ -n "${translations}" ]; then
+ sed -i -e "s:\(translations.extra =\) .*:\1 cp -p ${translations} \$(INSTALL_ROOT)\$\$PKGDATADIR/translations\r:" phoenix.pro || die
+ else
+ sed -i -e "s:translations.extra = .*:\r:" phoenix.pro || die
+ fi
+}
+
+src_configure() {
+ eqmake5 DEFINES=QUAZIP_INSTALLED PREFIX="${D}"/usr phoenix.pro
+}
diff --git a/sci-electronics/fritzing/metadata.xml b/sci-electronics/fritzing/metadata.xml
new file mode 100644
index 000000000000..922de4e32044
--- /dev/null
+++ b/sci-electronics/fritzing/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ <description>CC him on bugs.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fritzing/fritzing-app</remote-id>
+ </upstream>
+</pkgmetadata>