summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-01-02 07:41:20 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-01-02 07:42:33 -0700
commit89aa96291f6c4158352071cb705a38d46edda16a (patch)
tree4d5dfb93e7e95886a5202bd59c49cbbf6d25c2de /sci-chemistry/votca-csg/votca-csg-1.2.4-r1.ebuild
parentsci-chemistry/votca-csgapps: remove old (diff)
downloadgentoo-89aa96291f6c4158352071cb705a38d46edda16a.tar.gz
gentoo-89aa96291f6c4158352071cb705a38d46edda16a.tar.bz2
gentoo-89aa96291f6c4158352071cb705a38d46edda16a.zip
sci-chemistry/votca-csg: remove old
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-chemistry/votca-csg/votca-csg-1.2.4-r1.ebuild')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.2.4-r1.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-1.2.4-r1.ebuild b/sci-chemistry/votca-csg/votca-csg-1.2.4-r1.ebuild
deleted file mode 100644
index 295af05368e6..000000000000
--- a/sci-chemistry/votca-csg/votca-csg-1.2.4-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit bash-completion-r1 cmake-utils multilib
-
-IUSE="doc examples extras +gromacs"
-PDEPEND="extras? ( =sci-chemistry/votca-csgapps-${PV} )"
-if [ "${PV}" != "9999" ]; then
- SRC_URI="https://github.com/votca/downloads/raw/master/${P}.tar.gz
- doc? ( https://github.com/votca/downloads/raw/master/${PN}-manual-${PV}.pdf )
- examples? ( https://github.com/votca/downloads/raw/master/${PN}-tutorials-${PV}.tar.gz )"
-fi
-
-DESCRIPTION="Votca coarse-graining engine"
-HOMEPAGE="http://www.votca.org"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-macos"
-
-#perl is only used for scripts
-RDEPEND="~sci-libs/votca-tools-${PV}
- gromacs? ( <sci-chemistry/gromacs-5.1:= )
- dev-lang/perl
- app-shells/bash:0"
-
-DEPEND="${RDEPEND}
- doc? ( >=app-doc/doxygen-1.7.6.1[dot] )
- >=app-text/txt2tags-2.5
- virtual/pkgconfig"
-
-DOCS=(README NOTICE ChangeLog)
-
-src_configure() {
- local GMX_DEV="OFF" GMX_DOUBLE="OFF" extra
-
- if use gromacs; then
- has_version ">=sci-chemistry/gromacs-5" && GMX_DEV="ON"
- has_version sci-chemistry/gromacs[double-precision] && GMX_DOUBLE="ON"
- fi
-
- #to create man pages, build tree binaries are executed (bug #398437)
- [[ ${CHOST} = *-darwin* ]] && \
- extra+=" -DCMAKE_BUILD_WITH_INSTALL_RPATH=OFF"
-
- mycmakeargs=(
- $(cmake-utils_use_with gromacs GMX)
- -DWITH_GMX_DEVEL="${GMX_DEV}"
- -DGMX_DOUBLE="${GMX_DOUBLE}"
- ${extra}
- -DWITH_RC_FILES=OFF
- -DEXTERNAL_BOOST=ON
- -DLIB=$(get_libdir)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- newbashcomp scripts/csg-completion.bash csg_call
- for i in "${ED}"/usr/bin/csg_*; do
- [[ ${i} = *csg_call ]] && continue
- bashcomp_alias csg_call "${i##*/}"
- done
- if use doc; then
- if [ -n "${PV##*9999}" ]; then
- dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
- fi
- cd "${CMAKE_BUILD_DIR}" || die
- cd share/doc || die
- doxygen || die
- dohtml -r html/*
- fi
- if use examples && [ -n "${PV##*9999}" ]; then
- insinto "/usr/share/doc/${PF}/tutorials"
- docompress -x "/usr/share/doc/${PF}/tutorials"
- doins -r "${WORKDIR}/${PN}-tutorials-${PV}"/*
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "Please read and cite:"
- einfo "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
- einfo "http://dx.doi.org/10.1021/ct900369w"
- einfo
-}