summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/readseq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/readseq')
-rw-r--r--sci-biology/readseq/Manifest2
-rw-r--r--sci-biology/readseq/files/20080420-no-bundling.patch14
-rw-r--r--sci-biology/readseq/metadata.xml9
-rw-r--r--sci-biology/readseq/readseq-20080420-r1.ebuild42
-rw-r--r--sci-biology/readseq/readseq-20100513.ebuild38
5 files changed, 105 insertions, 0 deletions
diff --git a/sci-biology/readseq/Manifest b/sci-biology/readseq/Manifest
new file mode 100644
index 000000000000..bcd1dfa237bf
--- /dev/null
+++ b/sci-biology/readseq/Manifest
@@ -0,0 +1,2 @@
+DIST readseq-20100513.zip 628406 SHA256 878b689828bdf59a73c377c314fe504b9f18569ed5cd512acdb264cf90e72601 SHA512 6e2a2207e3a1f14e5cc4f7ffd2c74563b6deb088dda02727611359a17e1b157d9c661715d1f896d1573786cb88f61d3b952ab7a53e6dc30f2dcbcead58604b32 WHIRLPOOL 6f5b7ff075a081f521971689d014ad3ea6ffdc50db1b24766712d21fb86f83d7767f9afa76473f0be6f36560c8572c7051337cde8020cb9562dfef96a2bfdc8a
+DIST readseq-source-20080420.zip 627341 SHA256 d91ccadcbf5fde29525c639ece6ae132e0db863a7e63f96f69647e591617e8dd SHA512 cbc7afa46d2f0cfb30aa75ab88e4942a18ddf46a03a4cfb8d7e07bd23bce3fe015483899d371b947a0f1d6ec464b8c1238df7f7fc89753bb75dbb284f1e07b48 WHIRLPOOL fb180c53cb0555887d5278871498d66840d1d27da47ef6a947f0cd048bfb79762faf9493a645be6909bf41c5627131f3ced8d29b8241372d1e6034dc7524004d
diff --git a/sci-biology/readseq/files/20080420-no-bundling.patch b/sci-biology/readseq/files/20080420-no-bundling.patch
new file mode 100644
index 000000000000..f2e1708f8821
--- /dev/null
+++ b/sci-biology/readseq/files/20080420-no-bundling.patch
@@ -0,0 +1,14 @@
+diff --git a/build.xml b/build.xml
+index e3d723c..4b44d6f 100644
+--- a/build.xml
++++ b/build.xml
+@@ -229,9 +229,6 @@
+
+ <!-- for now, unjar xml classes into build/classes and rejar in readseq.jar -->
+
+- <unjar overwrite="false" src="${orgxml.jar}" dest="${build.home}/classes" />
+- <unjar overwrite="false" src="${xml.jar}" dest="${build.home}/classes" />
+-
+ <!-- <copy todir="${build.home}/classes""> -->
+ <!-- <src dir="${basedir}/META-INF"/> -->
+ <!-- </copy> -->
diff --git a/sci-biology/readseq/metadata.xml b/sci-biology/readseq/metadata.xml
new file mode 100644
index 000000000000..b198f044f3f5
--- /dev/null
+++ b/sci-biology/readseq/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ Reads and writes nucleic/protein sequences in various formats. Data
+ files may have multiple sequences.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/readseq/readseq-20080420-r1.ebuild b/sci-biology/readseq/readseq-20080420-r1.ebuild
new file mode 100644
index 000000000000..43c538beb596
--- /dev/null
+++ b/sci-biology/readseq/readseq-20080420-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-source-${PV}"
+DESCRIPTION="Reads and writes nucleic/protein sequences in various formats"
+HOMEPAGE="http://iubio.bio.indiana.edu/soft/molbio/readseq/"
+# Originally unversioned at
+# http://iubio.bio.indiana.edu/soft/molbio/readseq/java/readseq-source.zip.
+# Renamed to the date of the modification and mirrored
+SRC_URI="http://dev.gentoo.org/~dberkholz/distfiles/${MY_P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!=sci-biology/meme-4.8.1
+ >=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+java_prepare() {
+ rm "${S}"/lib/* || die
+ epatch "${FILESDIR}"/${PV}-*
+}
+
+src_install() {
+ java-pkg_dojar build/readseq.jar
+ java-pkg_dolauncher
+}
+
+pkg_postinst() {
+ elog "Documentation is available at"
+ elog "http://iubio.bio.indiana.edu/soft/molbio/readseq/java/Readseq2-help.html"
+}
diff --git a/sci-biology/readseq/readseq-20100513.ebuild b/sci-biology/readseq/readseq-20100513.ebuild
new file mode 100644
index 000000000000..6539ebd427cc
--- /dev/null
+++ b/sci-biology/readseq/readseq-20100513.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Reads and writes nucleic/protein sequences in various formats"
+HOMEPAGE="http://iubio.bio.indiana.edu/soft/molbio/readseq/"
+SRC_URI="http://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/${P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!=sci-biology/meme-4.8.1
+ >=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+java_prepare() {
+ rm "${S}"/lib/* || die
+ epatch "${FILESDIR}"/20080420-*
+}
+
+src_install() {
+ java-pkg_dojar build/readseq.jar
+ java-pkg_dolauncher
+}
+
+pkg_postinst() {
+ elog "Documentation is available at"
+ elog "http://iubio.bio.indiana.edu/soft/molbio/readseq/java/Readseq2-help.html"
+}