summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-07 15:43:29 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-07 20:39:48 +0000
commitaedade552fd238280d0f29afa6dcbe4c91c1ee26 (patch)
treeede9c8a357b7b888047f7398228fdf280269f466 /sci-astronomy/casacore/files
parentdev-ml/ppx_tools: add ocamlopt useflag, bug #624170 (diff)
downloadgentoo-aedade552fd238280d0f29afa6dcbe4c91c1ee26.tar.gz
gentoo-aedade552fd238280d0f29afa6dcbe4c91c1ee26.tar.bz2
gentoo-aedade552fd238280d0f29afa6dcbe4c91c1ee26.zip
sci-astronomy/casacore: remove buggy old.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-astronomy/casacore/files')
-rw-r--r--sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch45
-rw-r--r--sci-astronomy/casacore/files/casacore-disable-tpath-test.patch49
2 files changed, 0 insertions, 94 deletions
diff --git a/sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch b/sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch
deleted file mode 100644
index b14b7035c60c..000000000000
--- a/sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 3a45f84ccb6f08270fd6fd299eaf1b5401199d77 Mon Sep 17 00:00:00 2001
-From: Tammo Jan Dijkema <T.J.Dijkema@gmail.com>
-Date: Fri, 18 Mar 2016 10:43:13 +0100
-Subject: [PATCH] Add std to isinf and isnan, fixes #337
-
----
- casa/BasicMath/Math.cc | 4 ++--
- casa/BasicMath/test/tMathNaN.cc | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/casa/BasicMath/Math.cc b/casa/BasicMath/Math.cc
-index d1bd984..00659e3 100644
---- a/casa/BasicMath/Math.cc
-+++ b/casa/BasicMath/Math.cc
-@@ -178,7 +178,7 @@ Bool isInf(Float val) {
- // infinite. I can only have access to Solaris, Linux and SGI machines to
- // determine this.
- #if defined(AIPS_LINUX)
-- return (isinf(Double(val)));
-+ return (std::isinf(Double(val)));
- #elif defined(AIPS_DARWIN)
- return (std::isinf(Double(val)));
- #elif defined(AIPS_SOLARIS) || defined(AIPS_IRIX)
-@@ -212,7 +212,7 @@ Bool isInf(Double val) {
- // infinite. I can only have access to Solaris, Linux and SGI machines to
- // determine this.
- #if defined(AIPS_LINUX)
-- return (isinf(Double(val)));
-+ return (std::isinf(Double(val)));
- #elif defined(AIPS_DARWIN)
- return (std::isinf(Double(val)));
- #elif defined(AIPS_SOLARIS) || defined(AIPS_IRIX)
-diff --git a/casa/BasicMath/test/tMathNaN.cc b/casa/BasicMath/test/tMathNaN.cc
-index f1a73bc..0c330d1 100644
---- a/casa/BasicMath/test/tMathNaN.cc
-+++ b/casa/BasicMath/test/tMathNaN.cc
-@@ -43,7 +43,7 @@
- ((*(Int *)(x) & 0x007fffff) != 0x00000000))
-
- inline Bool isNaN_isnan(Float val) {
-- return (isnan(Double(val)));
-+ return (std::isnan(Double(val)));
- }
-
- inline Bool isNaN_isnanf(const Float& val) {
diff --git a/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch b/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch
deleted file mode 100644
index e92e1e7ac4f8..000000000000
--- a/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From: Benda Xu <heroxbd@gentoo.org>
-Date: Wed, 29 Oct 2014 16:40:47 +0900
-Subject: disable tPath test
-MIME-Version: 1.0
-Content-Type: text/plain; charset="utf-8"
-Content-Transfer-Encoding: 8bit
-
-Forwarded: no need
-Description: sbuild gets HOME variable leaked into the build environment
- Debian uses sbuild as official build farm. Until the cause is pinned down,
- this test is disabled.
-
- 98/425 Test #101: tPath ...............................***Failed 0.64 sec
-1,16d0
-< expanded: /home/heroxbd
-< expected: /«PKGBUILDDIR»
-< absolute: /home/heroxbd
-< expected: /«PKGBUILDDIR»
-< expanded: /home/heroxbd/test/test2
-< expected: /«PKGBUILDDIR»/test/test2
-< absolute: /home/heroxbd/test/test2
-< expected: /«PKGBUILDDIR»/test/test2
-< expanded: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-< absolute: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-< expanded: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-< absolute: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-33a18
-> OK
-FAIL (output not verified): ./tPath
----
- casa/OS/test/CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/casa/OS/test/CMakeLists.txt b/casa/OS/test/CMakeLists.txt
-index 4a31f7a..10d5b80 100644
---- a/casa/OS/test/CMakeLists.txt
-+++ b/casa/OS/test/CMakeLists.txt
-@@ -12,7 +12,6 @@ tMemory
- tMemoryTrace
- tModcompConversion
- tMutex
--tPath
- tPrecTimer
- tTime
- tTimer