summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2018-08-26 12:00:46 +0200
committerChristian Ruppert <idl0r@gentoo.org>2018-08-26 12:03:44 +0200
commitf5d04b2d993a3a68c8d56ac81ea57b1825599dd4 (patch)
tree0545eb29d36d74e291f17d9742fd0183e9661b95 /net-wireless/soapyremote/soapyremote-9999.ebuild
parentmedia-sound/timidity++: Fix build with GCC-5 (diff)
downloadgentoo-f5d04b2d993a3a68c8d56ac81ea57b1825599dd4.tar.gz
gentoo-f5d04b2d993a3a68c8d56ac81ea57b1825599dd4.tar.bz2
gentoo-f5d04b2d993a3a68c8d56ac81ea57b1825599dd4.zip
net-wireless/soapyremote: Initial import
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'net-wireless/soapyremote/soapyremote-9999.ebuild')
-rw-r--r--net-wireless/soapyremote/soapyremote-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/soapyremote/soapyremote-9999.ebuild b/net-wireless/soapyremote/soapyremote-9999.ebuild
new file mode 100644
index 000000000000..e1818a79ebcb
--- /dev/null
+++ b/net-wireless/soapyremote/soapyremote-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR remote module"
+HOMEPAGE="https://github.com/pothosware/SoapyRemote"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyRemote.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyRemote/archive/soapy-remote-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyRemote-soapy-remote-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr"
+DEPEND="${RDEPEND}"