summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-12-06 11:14:52 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-12-06 11:15:11 -0600
commitb53bfc84e97e7948feda5524477ab1918596f52e (patch)
tree906308475b9e5546cd38a3c11705b00d2c9fad56 /net-vpn
parentdev-python/pyqt6-sip: add 13.9.0 (diff)
downloadgentoo-b53bfc84e97e7948feda5524477ab1918596f52e.tar.gz
gentoo-b53bfc84e97e7948feda5524477ab1918596f52e.tar.bz2
gentoo-b53bfc84e97e7948feda5524477ab1918596f52e.zip
net-vpn/tailscale: add 1.78.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.78.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 29b54b75a686..c4d5c6e377ec 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -1,2 +1,4 @@
DIST tailscale-1.74.1-deps.tar.xz 254129372 BLAKE2B e9e0fea2ba83d3ad23e4b26c0e86149c321d6f236f0ff30a019ed0aab6ed1568f3516832cd6af0ef904359308fefdfd7a9394af3859e503a0afc6e0cc28b7cd7 SHA512 32b3829c79733a4d86b0a40a09a5c8236604608bf490756f7a76c835d0688e79318837d2db9a1459afd7186b326c924c01d0431376ab76a6a0fbcfdd11c15811
DIST tailscale-1.74.1.tar.gz 3237654 BLAKE2B c54eb1338b2d017607213ef810d3accc64adc82efa60839c37c1298b79e61e56f472e329b237e32d270c8725fde678214b6c1290901d7fad1563451904a38bca SHA512 795aa53b4681a9e5f8316651d33bc9a0724fb75cba99847db01e3b0f29d6957b3588fea77347ce9d53d28154883458cac8d54ccd08ebbb31cc00294158d7780f
+DIST tailscale-1.78.1-deps.tar.xz 265614604 BLAKE2B 590c750ff34b3044793ebffc433583e5d904b19d5aaa7926f644c0251df3b5cad32f3da06daa1cfb16bdeb50f63e62c21f893515aa2cae8d2be04b81233c8664 SHA512 6a738f98a9eba65ccc8989c9edaa24fa4db545c0d10a973613066734b7f379f99261eb4d5e8f49345d314336891fb6c9e9a45456784a38963b4a552147fbc631
+DIST tailscale-1.78.1.tar.gz 3378628 BLAKE2B f8f6dfaf5498eb7a230035373d1b1d501da3296e394083d26870596bacf5e6a1f4d849a016dc652ba3e416de960a2a5483aa5e3b44b33b6759f42959cd7208ab SHA512 1286971554f15c601ee36050cbe361170de2ea4955fc8dde01a4a231f966a1049b9d85d2854637077c1900d4e67ef15352250e412f9e13b2d1cb6b34b2dce05a
diff --git a/net-vpn/tailscale/tailscale-1.78.1.ebuild b/net-vpn/tailscale/tailscale-1.78.1.ebuild
new file mode 100644
index 000000000000..822dbdc2f417
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.78.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+# They should be updated on every bump.
+VERSION_MINOR="78"
+VERSION_SHORT="1.78.1"
+VERSION_LONG="1.78.1-tc80eb698d"
+VERSION_GIT_HASH="c80eb698d5057b04d826b5ae2004d4c464ae28f6"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CONFIG_CHECK="~TUN"
+
+RDEPEND="net-firewall/iptables"
+BDEPEND=">=dev-lang/go-1.22"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.longStamp=${VERSION_LONG}
+ -X tailscale.com/version.shortStamp=${VERSION_SHORT}
+ -X tailscale.com/version.gitCommitStamp=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}