summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-04-15 15:07:20 +0800
committerYixun Lan <dlan@gentoo.org>2019-04-15 15:11:34 +0800
commit34da8fc9b7346abe20d3f97fe319bc849a0518dc (patch)
tree75cffba110d9e60cac252b5784a622077980d9c1 /net-vpn/tinc
parentdev-vcs/subversion: Synced release candidate (diff)
downloadgentoo-34da8fc9b7346abe20d3f97fe319bc849a0518dc.tar.gz
gentoo-34da8fc9b7346abe20d3f97fe319bc849a0518dc.tar.bz2
gentoo-34da8fc9b7346abe20d3f97fe319bc849a0518dc.zip
net-vpn/tinc: fix icmpv6 checksum error
backport the patch from tinc-1.1 branch, thanks Benda Xu for testing Closes: https://bugs.gentoo.org/683160 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-vpn/tinc')
-rw-r--r--net-vpn/tinc/Manifest1
-rw-r--r--net-vpn/tinc/tinc-1.0.35-r2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-vpn/tinc/Manifest b/net-vpn/tinc/Manifest
index e161801b3993..63c79ddf9211 100644
--- a/net-vpn/tinc/Manifest
+++ b/net-vpn/tinc/Manifest
@@ -1,4 +1,5 @@
DIST tinc-1.0.35-upstream-patches-0.tar.xz 2884 BLAKE2B a01ee1a372cc366402c005a48adccd7e31bd3182c1fc6df2dc27aecd622266be06f2c25aa169794b2970fe1f8218b7fa813365f8852e165ed2356ed885c5fde3 SHA512 c95add88e05dc7dc8d09618dd07870e400e1fe28c8f864acbf131d9616d75337fd1d2d7b44ee80c3f31e1b713f258bb9d575956114e73fea781488d2b477a5f5
+DIST tinc-1.0.35-upstream-patches-1.tar.xz 6028 BLAKE2B d236125211efda0c8b5aa4e93a278fec17d57ecb257ea057ca67f2a465d1da7d069f6d3a97220dc1e40123266bc2fc68685d2ea2e143033a12199278b073c31b SHA512 8ae2b96d5f296bc5d0d21fa814832ccafdb5595b06d60d72a090eadb4aade9e386990801b5e1a8cca722f88881aa2d21e70f9154570feede6a9771a0eaec83ab
DIST tinc-1.0.35.tar.gz 499277 BLAKE2B 419b581167614d534b6f2f3b804657f088c013529d7738766aff199da775860ffed42ecb61e8ed008c5b6fa410f071e2fe1ca59f0c6e443c0a8017cd10c31ce3 SHA512 037867306c21506d57d69d35c0f246b2936022047978fa3e01464b5f6b65f109760507d9cc740f82f8166f39c5ce44d9f8dde55655a6372dacd5b5974aeaee32
DIST tinc-1.1-upstream-patches-2.tar.xz 23500 BLAKE2B ab44d2efcd494c6a49e9e0bc109670a586b087d5ce1daab9b9cdf8f50a4c9b9d927e102fe947e75e6f7be509ba9315936315006b557b39639399bc7f40109f5f SHA512 351537f212421e7fe28fcf97293550edaa4c4c8a578bf4eeca34ae591caefb222df4d5d96bfa03bddd6afcb5143e68b59f5341b2a6412c053a3cecf4fdd0bee8
DIST tinc-1.1pre16.tar.gz 703679 BLAKE2B c02636f52983c1fdebe28058a5e49f3952ac10b238c9d8f01a10b140960803f197a057c883860ca259b949883c406cf74f518d0e45bf84f10566a964570daf9b SHA512 b32a0a734a4c8a91bad4cef4177cb45757c97c09dc179da1e3357f2fde48b3b0747587dbac31ecb5400e1553b6712d474a6a1808ac24bce1a3494c1842bb6c43
diff --git a/net-vpn/tinc/tinc-1.0.35-r2.ebuild b/net-vpn/tinc/tinc-1.0.35-r2.ebuild
new file mode 100644
index 000000000000..7f3390de4c16
--- /dev/null
+++ b/net-vpn/tinc/tinc-1.0.35-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+
+UPSTREAM_VER=1
+
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="libressl +lzo uml vde +zlib"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+# Upstream's patchset
+if [[ -n ${UPSTREAM_VER} ]]; then
+ PATCHES=( "${WORKDIR}"/patches-upstream )
+fi
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r1 tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+}