summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfe İzbudak <efe.izbudak@metu.edu.tr>2023-07-13 07:32:29 -0400
committerSam James <sam@gentoo.org>2023-07-26 04:32:50 +0100
commita948c22a3af74fdd0ce902cea6ef2c1bcc19c785 (patch)
treed345a0b5e1f71d4c007f2b0959c034cf3b2babec /net-p2p
parentdev-perl/Net-SSH-Perl: add 2.141.0 (diff)
downloadgentoo-a948c22a3af74fdd0ce902cea6ef2c1bcc19c785.tar.gz
gentoo-a948c22a3af74fdd0ce902cea6ef2c1bcc19c785.tar.bz2
gentoo-a948c22a3af74fdd0ce902cea6ef2c1bcc19c785.zip
net-p2p/nicotine+: needs python[gdbm]
Nicotine+ needs python[gdbm] as a runtime dependency. Signed-off-by: Efe İzbudak <efe.izbudak@metu.edu.tr> Closes: https://github.com/gentoo/gentoo/pull/31865 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild b/net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild
new file mode 100644
index 000000000000..bbf1e8854cf3
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="gdbm"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+EPYTEST_IGNORE=(
+ "test/integration/test_startup.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}