summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-11-13 10:39:07 -0500
committerCraig Andrews <candrews@gentoo.org>2023-11-13 10:39:28 -0500
commit04402fcf48f4b94b3f151e21becf61ceb5186208 (patch)
tree27973a0a480e015994e2ba65ad285a1806e680eb /net-p2p
parentdev-python/sphinxcontrib-github-alt: enable py3.12 (diff)
downloadgentoo-04402fcf48f4b94b3f151e21becf61ceb5186208.tar.gz
gentoo-04402fcf48f4b94b3f151e21becf61ceb5186208.tar.bz2
gentoo-04402fcf48f4b94b3f151e21becf61ceb5186208.zip
net-p2p/cpuminer-opt: add 23.9
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-23.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index f3092ef2cf7e..239bff085d32 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-23.8.tar.gz 1789910 BLAKE2B 944cf64457b9eb37726e1d0f0976dbb61a67a8690803e0f5b1914770cdcfba760fa554f389f3a4da97256b57c2b76ae5516b8b2d864d09667aeeaa7ec9af8825 SHA512 dc1a9f635f7aa9b751f6f9a070e2665cecb95d0f859b0cdf77b2b5ba906724a567d00fb5d9542b063e381c3bcf1840997bf37534bde59fb667d9b2002fa0d67b
+DIST cpuminer-opt-23.9.tar.gz 1789859 BLAKE2B a1a4594100a28c5eba9a2db3284944e61bb96b7fa118c44a4a97d66ada8df33f0e6feb74fb0cc507598b23980cd32f2839c5dc54abd4520fb875ab465da9d657 SHA512 76d81dcac0c631c46b1fa5b8c5918b21b900cafa00f1a56f72af87924b90b2c947b09f5aaed30d478e6e0e77b3ac6111e3e537e52460514185e3d2787db5ca11
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-23.9.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-23.9.ebuild
new file mode 100644
index 000000000000..7a6224bf33d8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-23.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ newins config-template.json cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}