summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-18 12:54:26 +0000
committerSam James <sam@gentoo.org>2024-02-18 12:54:41 +0000
commit0b94789f5b004fe13ca756b8e9be67bd31ec2344 (patch)
treec50134882d9d9a81d1edbff059720c4f783e0b3f /net-nntp/sabnzbd
parentwww-apps/chromedriver-bin: add 121.0.6167.184 (diff)
downloadgentoo-0b94789f5b004fe13ca756b8e9be67bd31ec2344.tar.gz
gentoo-0b94789f5b004fe13ca756b8e9be67bd31ec2344.tar.bz2
gentoo-0b94789f5b004fe13ca756b8e9be67bd31ec2344.zip
net-nntp/sabnzbd: fixup pytest plugin handling
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp/sabnzbd')
-rw-r--r--net-nntp/sabnzbd/sabnzbd-4.2.2.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-nntp/sabnzbd/sabnzbd-4.2.2.ebuild b/net-nntp/sabnzbd/sabnzbd-4.2.2.ebuild
index f035384b9b22..0cc03bdddd59 100644
--- a/net-nntp/sabnzbd/sabnzbd-4.2.2.ebuild
+++ b/net-nntp/sabnzbd/sabnzbd-4.2.2.ebuild
@@ -93,8 +93,6 @@ src_test() {
'tests/test_newswrapper.py::TestNewsWrapper'
'tests/test_happyeyeballs.py::TestHappyEyeballs'
'tests/test_internetspeed.py::TestInternetSpeed'
- # Doesn't work, fixture 'fs' not found
- 'tests/test_dirscanner.py::TestDirScanner'
# Just plain fails
'tests/test_newsunpack.py::TestPar2Repair::test_basic'
# Chromedriver tests don't want to behave in portage
@@ -116,8 +114,17 @@ src_test() {
'tests/test_functional_sorting.py::TestDownloadSorting'
)
+ # The test suite is prone to being broken by random plugins that happen
+ # to be installed, so disable autoloading.
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -s -p pytest_mock -p tavern
+ # Use PYTEST_PLUGINS instead of args to 'epytest' because the test suite
+ # calls pytest itself and the args would get lost. To get the list of plugins,
+ # if stuck, comment out the AUTOLOAD line above, look at the list of loaded
+ # plugins at the top of the pytest output, then translate those into module names
+ # by e.g. checking equery f.
+ local -x PYTEST_PLUGINS=pytest_mock,tavern,tavern._core.pytest,pyfakefs.pytest_plugin
+
+ epytest -s
}
src_install() {