summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-15 14:00:35 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-15 14:14:54 +0100
commit6b23fdfc0f9e42305aeb176bbd7ec3f9016b6b04 (patch)
tree7d1915fb86b1b7ad254ef77cbcb1bd8fde8cbc88 /net-news
parentapp-metrics/prometheus-lvm-exporter: add 0.3.3, systemd, cleanup (diff)
downloadgentoo-6b23fdfc0f9e42305aeb176bbd7ec3f9016b6b04.tar.gz
gentoo-6b23fdfc0f9e42305aeb176bbd7ec3f9016b6b04.tar.bz2
gentoo-6b23fdfc0f9e42305aeb176bbd7ec3f9016b6b04.zip
net-news/rssguard: Bump to 4.6.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rssguard/Manifest1
-rw-r--r--net-news/rssguard/rssguard-4.6.6.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
index 5f8c1c3c9cfe..399f26968a26 100644
--- a/net-news/rssguard/Manifest
+++ b/net-news/rssguard/Manifest
@@ -1 +1,2 @@
DIST rssguard-4.6.3.gh.tar.gz 23360644 BLAKE2B 7906d8d38abf147dfa1938f3b847409642a971a4114cf77d99191215933c8f6204a0ba2f5815828bbb048c65e9724be1742056fee7570fc7aa388cc70ffa2f22 SHA512 3563e5df821dea6d617eeebaa8d956c0a2b43cddfef783b01079309511b394d677f84e13d8600eaa0f83c627186d5c1955db646e7758084bf162b8af0f2d8952
+DIST rssguard-4.6.6.gh.tar.gz 23432162 BLAKE2B f9febdc9d91ebfd4f8e8ade9de7b9ba6748bea9f5fa0e3ced0c4eaa908daedcbc2ae31c77e472418a05a8aca7fc30c7d56ab19aa144df40ea14a4530ac520e3d SHA512 82dbc1e5cbc527a965d17afe77aea978908544c2f8997a134749374e6acaf287de90c6be9a8e818c1097f826b54af94731f5f39fa9232ff8ee2491ac99e24063
diff --git a/net-news/rssguard/rssguard-4.6.6.ebuild b/net-news/rssguard/rssguard-4.6.6.ebuild
new file mode 100644
index 000000000000..3625148b6cb5
--- /dev/null
+++ b/net-news/rssguard/rssguard-4.6.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature xdg
+
+DESCRIPTION="Simple (yet powerful) news feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard/"
+SRC_URI="
+ https://github.com/martinrotter/rssguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( LGPL-3 GPL-2+ ) AGPL-3+ BSD GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libmpv mysql qt6 qtmultimedia +sqlite webengine"
+REQUIRED_USE="
+ || ( mysql sqlite )
+ ?? ( libmpv qtmultimedia )
+"
+
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+DEPEND="
+ sys-libs/zlib:=
+ libmpv? ( media-video/mpv:= )
+ !qt6? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[gstreamer]
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[mysql?,sqlite?]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ libmpv? (
+ dev-qt/qtopengl:5
+ )
+ qtmultimedia? (
+ dev-qt/qtmultimedia:5
+ dev-qt/qtopengl:5
+ )
+ webengine? ( dev-qt/qtwebengine:5[widgets(+)] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent,dbus,gui,mysql?,network,sql,sqlite?,ssl,widgets]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtmultimedia:6[gstreamer]
+ dev-qt/qt5compat:6
+ media-libs/libglvnd
+ libmpv? (
+ dev-qt/qtbase:6[opengl]
+ )
+ qtmultimedia? (
+ dev-qt/qtbase:6[opengl]
+ dev-qt/qtmultimedia:6
+ )
+ webengine? ( dev-qt/qtwebengine:6[widgets(+)] )
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=$(usex qt6)
+ -DNO_LITE=$(usex webengine)
+ -DREVISION_FROM_GIT=OFF
+ -DNO_UPDATE_CHECK=ON
+ -DENABLE_COMPRESSED_SITEMAP=ON
+ -DENABLE_MEDIAPLAYER_QTMULTIMEDIA=$(usex qtmultimedia)
+ -DENABLE_MEDIAPLAYER_LIBMPV=$(usex libmpv)
+ # recommended
+ -DMEDIAPLAYER_FORCE_OPENGL=ON
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "ad blocking functionality" "net-libs/nodejs[npm]"
+}