summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-11 15:11:56 +0000
committerSam James <sam@gentoo.org>2024-11-11 15:19:15 +0000
commita46c7c97eeed570979f55ebc6084e1acaa2977cc (patch)
tree5317ed5aee45cb2c3859ba5c4feef5130332640c /net-misc
parentsec-keys/openpgp-keys-wget: add 20241111 (diff)
downloadgentoo-a46c7c97eeed570979f55ebc6084e1acaa2977cc.tar.gz
gentoo-a46c7c97eeed570979f55ebc6084e1acaa2977cc.tar.bz2
gentoo-a46c7c97eeed570979f55ebc6084e1acaa2977cc.zip
net-misc/wget: add 1.25.0
Bug: https://bugs.gentoo.org/943275 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/Manifest2
-rw-r--r--net-misc/wget/wget-1.25.0.ebuild121
2 files changed, 123 insertions, 0 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index e044038e618e..b3c356603f53 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -2,3 +2,5 @@ DIST wget-1.21.4.tar.gz 5059591 BLAKE2B ced6fb9a20343d41e4d8e0c8f171c60535847504
DIST wget-1.21.4.tar.gz.sig 854 BLAKE2B 162c4f358e781bbfb0fa73910191c29dd411f48c9b2c8e8fe00a12741153e624955393d769aa7311b03115d04b6b946a84b636f643d7cdc8c8cd81387b9cf143 SHA512 72603493c2d799dca08700175a2010d8736fd6d3cb9bea3987db8814e9f133ab0fbd1477892115f7fbbd1a7d4d416ec370bdbff6dbe8f00d1eea84f0c4f8d84b
DIST wget-1.24.5.tar.lz 2545954 BLAKE2B 8057e5992ddaf39b3daffbde99871ddec1328c6bbafbc6b9f1d3cd294bb928b2a80f813024d4cd664c396f84477f1d93d5a21c60c6fe2932f9196d29bb9aa896 SHA512 d8972e94d9125133d115750542e0f126b85a311634d5563a69d8fe85ecf1200836dcc83528ee4285d56834c58c722be580bfe749b26436158fbe4afc566f5cc0
DIST wget-1.24.5.tar.lz.sig 854 BLAKE2B 395e7da40e33f9a1df4978440f79e69eec951344d6c78a71e2867e4764ce552ccda3a4d34fa211b0d8abf18d87cf15dd8a0c5a8c43ffcc92e1b75c8d3bce9665 SHA512 5bc3e578fe55b7f954aec61101cb2d7f97a9464e61d5500caa47ac8b22048910c91f8ad22966fcb05c62414be76a1275805ac27ed434fa9de4d30f7a3631fd29
+DIST wget-1.25.0.tar.lz 2582072 BLAKE2B 58edd7393b5109804d7a6ce77466d30e1fba3c5ae4b5b8634758c9ebd7fa95cf106d35ad0b4f9151833d88b0221fc488a1005ec0b98417766bf2092309744954 SHA512 79403f594636e5d703817ceec59e5155940cd4734746ef793ef3bdabd100d0014a44c5e24f705656cf1e0762d87003fa1dc3e1b5605fae392bc9d7f121d90bae
+DIST wget-1.25.0.tar.lz.sig 854 BLAKE2B 0698971ffdab274ee20d84b84096e9d4bd4a75b57df41643c55304188b3fcce69624a4d7043fb47280a63fb74748c2ce67ff1c6efc929680c8d2aee93498d309 SHA512 06a575b3e16f586c7c7affa2c80b4714bfbcd0aa03305126b16dcc34bd011b1690c71935111cde5f43e0fea214dc11d2da1fb98828c4e913da8c83159d8791e0
diff --git a/net-misc/wget/wget-1.25.0.ebuild b/net-misc/wget/wget-1.25.0.ebuild
new file mode 100644
index 000000000000..9c72b648f3db
--- /dev/null
+++ b/net-misc/wget/wget-1.25.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/wget.asc
+inherit flag-o-matic python-any-r1 toolchain-funcs unpacker verify-sig
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="https://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.lz"
+SRC_URI+=" verify-sig? ( mirror://gnu/wget/${P}.tar.lz.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="cookie-check debug gnutls idn ipv6 libproxy metalink nls ntlm pcre +ssl static test uuid zlib"
+REQUIRED_USE="ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
+RESTRICT="!test? ( test )"
+
+# * Force a newer libidn2 to avoid libunistring deps. #bug #612498
+# * Metalink can use gpgme automagically (so let's always depend on it)
+# for signed metalink resources.
+LIB_DEPEND="
+ cookie-check? ( net-libs/libpsl )
+ idn? ( >=net-dns/libidn2-0.14:=[static-libs(+)] )
+ libproxy? ( net-libs/libproxy )
+ metalink? (
+ app-crypt/gpgme
+ media-libs/libmetalink
+ )
+ pcre? ( dev-libs/libpcre2[static-libs(+)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:=[static-libs(+)] )
+ !gnutls? ( dev-libs/openssl:=[static-libs(+)] )
+ )
+ uuid? ( sys-apps/util-linux[static-libs(+)] )
+ zlib? ( sys-libs/zlib[static-libs(+)] )
+"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="
+ ${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+"
+BDEPEND="
+ $(unpacker_src_uri_depends)
+ app-arch/xz-utils
+ dev-lang/perl
+ sys-apps/texinfo
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ >=dev-perl/HTTP-Daemon-6.60.0
+ dev-perl/HTTP-Message
+ dev-perl/IO-Socket-SSL
+ )
+ verify-sig? ( >=sec-keys/openpgp-keys-wget-20241111 )
+"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README )
+
+# gnulib FPs
+QA_CONFIG_IMPL_DECL_SKIP=( unreachable MIN alignof static_assert fpurge )
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_unpack() {
+ use verify-sig && verify-sig_verify_detached "${DISTDIR}"/${P}.tar.lz{,.sig}
+ unpacker ${P}.tar.lz
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr/local/etc:${EPREFIX}/etc:g" doc/{sample.wgetrc,wget.texi} || die
+}
+
+src_configure() {
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
+
+ if use static ; then
+ append-ldflags -static
+ tc-export PKG_CONFIG
+ PKG_CONFIG+=" --static"
+ fi
+
+ # There is no flag that controls this. libunistring-prefix only
+ # controls the search path (which is why we turn it off below).
+ # Further, libunistring is only needed w/older libidn2 installs,
+ # and since we force the latest, we can force off libunistring. # bug #612498
+ local myeconfargs=(
+ ac_cv_libunistring=no
+ --disable-assert
+ --disable-pcre
+ --disable-rpath
+ --without-included-libunistring
+ --without-libunistring-prefix
+ $(use_enable debug)
+ $(use_enable idn iri)
+ $(use_enable ipv6)
+ $(use_enable nls)
+ $(use_enable ntlm)
+ $(use_enable pcre pcre2)
+ $(use_enable ssl digest)
+ $(use_enable ssl opie)
+ $(use_with cookie-check libpsl)
+ $(use_enable idn iri)
+ $(use_enable libproxy)
+ $(use_with metalink)
+ $(use_with ssl ssl $(usex gnutls gnutls openssl))
+ $(use_with uuid libuuid)
+ $(use_with zlib)
+ )
+
+ econf "${myeconfargs[@]}"
+}