summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-06 05:37:08 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-06 05:37:22 +0100
commit8b17f069ed9dda16a88392918895acd88fb296c1 (patch)
tree6c948ed006e9446d39f2afacbf1b25374468fb03 /net-misc
parentdev-python/sentry-sdk: Remove last-rited pkg (diff)
downloadgentoo-8b17f069ed9dda16a88392918895acd88fb296c1.tar.gz
gentoo-8b17f069ed9dda16a88392918895acd88fb296c1.tar.bz2
gentoo-8b17f069ed9dda16a88392918895acd88fb296c1.zip
net-misc/electron-cash: Remove last-rited pkg
Bug: https://bugs.gentoo.org/941436 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/electron-cash/Manifest1
-rw-r--r--net-misc/electron-cash/electron-cash-4.2.11.ebuild158
-rw-r--r--net-misc/electron-cash/files/3.3.6-no-user-root.patch27
-rw-r--r--net-misc/electron-cash/metadata.xml21
4 files changed, 0 insertions, 207 deletions
diff --git a/net-misc/electron-cash/Manifest b/net-misc/electron-cash/Manifest
deleted file mode 100644
index ac4a3f1698a5..000000000000
--- a/net-misc/electron-cash/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST electron-cash-4.2.11.tar.gz 8039918 BLAKE2B 3139647fd22aaa88ff9a514b83e12dd3b36abb6affe9b51b270e1936f4d37ec3ea867ebcfe388f428392093996d2bf7d1268ee0b2447c5d559a39c3e35745dfc SHA512 7b01d2d94b29a3f054738cd89344a7c15136f90d6aa66dd587da315471aeb053bee1d7bbeab46016054b7dd98915bb2225a381d082a8fd137997c05957e2d44a
diff --git a/net-misc/electron-cash/electron-cash-4.2.11.ebuild b/net-misc/electron-cash/electron-cash-4.2.11.ebuild
deleted file mode 100644
index 29c18e34d5e1..000000000000
--- a/net-misc/electron-cash/electron-cash-4.2.11.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-PYTHON_REQ_USE="ncurses?"
-
-inherit desktop distutils-r1 xdg-utils
-
-MY_P="Electron-Cash-${PV}"
-DESCRIPTION="Lightweight Bitcoin Cash client (BCH fork of Electrum)"
-HOMEPAGE="https://github.com/Electron-Cash/Electron-Cash"
-SRC_URI="https://github.com/Electron-Cash/Electron-Cash/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="amodem cli cosign digitalbitbox email ncurses qrcode +qt5 sync vkb
- l10n_es l10n_ja l10n_pt l10n_zh-CN"
-RESTRICT+=" test"
-
-REQUIRED_USE="
- || ( cli ncurses qt5 )
- amodem? ( qt5 )
- cosign? ( qt5 )
- digitalbitbox? ( qt5 )
- email? ( qt5 )
- qrcode? ( qt5 )
- sync? ( qt5 )
- vkb? ( qt5 )
-"
-
-BDEPEND="${DISTUTILS_DEPS}"
-
-RDEPEND="
- dev-python/dnspython[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/jsonrpclib[${PYTHON_USEDEP}]
- dev-python/pathvalidate[${PYTHON_USEDEP}]
- dev-python/pbkdf2[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- dev-python/pysocks[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/protobuf[${PYTHON_USEDEP}]
- net-libs/stem[${PYTHON_USEDEP}]
- amodem? ( dev-python/amodem[${PYTHON_USEDEP}] )
- qrcode? ( media-gfx/zbar[v4l] )
- qt5? (
- dev-python/pyqt5[gui,widgets,${PYTHON_USEDEP}]
- )
- ncurses? ( dev-lang/python )
- dev-libs/libsecp256k1
-"
-
-distutils_enable_tests pytest
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="RELEASE-NOTES"
-
-src_prepare() {
- eapply "${FILESDIR}/3.3.6-no-user-root.patch"
-
- # Prevent icon from being installed in the wrong location
- sed -e '/icons/d' \
- -e "s:\\(os.path.join(\\)share_dir:\\1'share':" \
- -i setup.py || die
-
- if use qt5; then
- pyrcc5 icons.qrc -o electroncash_gui/qt/icons_rc.py || die
- else
- sed "s|'electroncash_gui.qt',||" -i setup.py || die
- fi
-
- local wordlist=
- for wordlist in \
- $(usex l10n_ja '' japanese) \
- $(usex l10n_pt '' portuguese) \
- $(usex l10n_es '' spanish) \
- $(usex l10n_zh-CN '' chinese_simplified) \
- ; do
- rm -f "electroncash/wordlist/${wordlist}.txt" || die
- sed -i "/${wordlist}\\.txt/d" electroncash/mnemonic.py || die
- done
-
- # Remove unrequested GUI implementations:
- local gui setup_py_gui
- for gui in \
- $(usex cli '' stdio) \
- $(usex qt5 '' qt ) \
- $(usex ncurses '' text ) \
- ; do
- rm electroncash_gui/"${gui}"* -r || die
- done
-
- # And install requested ones...
- for gui in \
- $(usex qt5 qt '') \
- ; do
- setup_py_gui="${setup_py_gui}'electrum_gui.${gui}',"
- done
-
- sed -i "s/'electrum_gui\\.qt',/${setup_py_gui}/" setup.py || die
-
- local bestgui
- if use qt5; then
- bestgui=qt
- elif use ncurses; then
- bestgui=text
- else
- bestgui=stdio
- fi
- sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' "${PN}" || die
-
- local plugin
- # trezor requires python trezorlib module
- # keepkey requires trezor
- for plugin in \
- $(usex amodem '' audio_modem ) \
- $(usex cosign '' cosigner_pool ) \
- $(usex digitalbitbox '' digitalbitbox ) \
- $(usex email '' email_requests ) \
- hw_wallet \
- ledger \
- keepkey \
- $(usex sync '' labels ) \
- trezor \
- $(usex vkb '' virtualkeyboard ) \
- ; do
- rm -r electroncash_plugins/"${plugin}"* || die
- sed -i "/${plugin}/d" setup.py || die
- done
-
- eapply_user
-
- distutils-r1_src_prepare
-}
-
-src_install() {
- doicon -s 128 icons/${PN}.png
- distutils-r1_src_install
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/net-misc/electron-cash/files/3.3.6-no-user-root.patch b/net-misc/electron-cash/files/3.3.6-no-user-root.patch
deleted file mode 100644
index f5f0aecf382f..000000000000
--- a/net-misc/electron-cash/files/3.3.6-no-user-root.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -33,23 +33,7 @@
- # Use per-user */share directory if the global one is not writable or if a per-user installation
- # is attempted
- user_share = os.environ.get('XDG_DATA_HOME', os.path.expanduser('~/.local/share'))
-- system_share = os.path.join(opts.prefix_path, "share")
-- if not opts.is_user:
-- # Not neccarily a per-user installation try system directories
-- if os.access(opts.root_path + system_share, os.W_OK):
-- # Global /usr/share is writable for us – so just use that
-- share_dir = system_share
-- elif not os.path.exists(opts.root_path + system_share) and os.access(opts.root_path, os.W_OK):
-- # Global /usr/share does not exist, but / is writable – keep using the global directory
-- # (happens during packaging)
-- share_dir = system_share
-- else:
-- # Neither /usr/share (nor / if /usr/share doesn't exist) is writable, use the
-- # per-user */share directory
-- share_dir = user_share
-- else:
-- # Per-user installation
-- share_dir = user_share
-+ share_dir = os.path.join(opts.prefix_path, "share")
- data_files += [
- # Menu icon
- # Menu entry
diff --git a/net-misc/electron-cash/metadata.xml b/net-misc/electron-cash/metadata.xml
deleted file mode 100644
index 213f5fe41bbc..000000000000
--- a/net-misc/electron-cash/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- <name>Zac Medico</name>
- </maintainer>
- <use>
- <flag name="cli">Enables the CLI interface</flag>
- <flag name="amodem">Enable plugin to support Audio Modem</flag>
- <flag name="cosign">Enable plugin to support multisig wallets between multiple Electrum clients</flag>
- <flag name="digitalbitbox">Enable plugin to support Digital Bitbox hardware wallet</flag>
- <flag name="email">Enable plugin to support emailing invoices</flag>
- <flag name="qrcode">Enable QR code scanning with <pkg>media-gfx/zbar</pkg></flag>
- <flag name="sync">Enable plugin to sync wallet metadata across multiple Electrum clients</flag>
- <flag name="vkb">Enable plugin for virtual keyboard</flag>
- </use>
- <upstream>
- <remote-id type="github">Electron-Cash/Electron-Cash</remote-id>
- </upstream>
-</pkgmetadata>