summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-04-09 15:40:33 +0530
committerZac Medico <zmedico@gentoo.org>2024-04-17 21:04:09 -0700
commit70fe93a03cd313515f7f87193282b67f7958a947 (patch)
tree17e03ac12900a801f78806e461faa110d85852b1 /net-misc
parentsys-apps/systemd: Stabilize 254.10 sparc, #930180 (diff)
downloadgentoo-70fe93a03cd313515f7f87193282b67f7958a947.tar.gz
gentoo-70fe93a03cd313515f7f87193282b67f7958a947.tar.bz2
gentoo-70fe93a03cd313515f7f87193282b67f7958a947.zip
net-misc/passt: update to 2024.04.05
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/36173 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/passt/Manifest1
-rw-r--r--net-misc/passt/passt-2024.04.05.ebuild40
-rw-r--r--net-misc/passt/passt-9999.ebuild2
3 files changed, 42 insertions, 1 deletions
diff --git a/net-misc/passt/Manifest b/net-misc/passt/Manifest
index 4ed5efa8b832..11f5c4743bd1 100644
--- a/net-misc/passt/Manifest
+++ b/net-misc/passt/Manifest
@@ -2,3 +2,4 @@ DIST passt-2023.12.04.tar.xz 188136 BLAKE2B f1d72fbb4bbb25f6a11e9ff87a91cf9bac06
DIST passt-2023.12.30.tar.xz 188596 BLAKE2B 75712a7cb7a00fea20427979153090d938b8c7b0e3da61c83cabb3751786034df35ebbe8afbd991d582a680f55b12792547b68efa931a5576dc181040b31e5fd SHA512 4b19d191e2526bacc61bb8ab2964f5da4e0535656b094a7592f91d6b437c855a586fc772e2abd89138ff4f89aae12ade494c6e0fe7bee1502fe319215200d8f0
DIST passt-2024.03.20.tar.xz 195332 BLAKE2B 1bed740ddd235f300a4233fb2024f155758809589f1fdd2174ab99a8a93dd16044ab41814b215d12eb1e557966a73a3754bbff2b9acd752b45b385edd88ba3c7 SHA512 3701820e539545771d0f867fe0b8977cb5967e7501413f717fed08d2d2c141f17d86ed7238177b4fb4cf4cfc01c6c9d07e3c218c34b48e0a5a1f2b2ce8a5b903
DIST passt-2024.03.26.tar.xz 195348 BLAKE2B d91e6ac1d50aae04ceb53a34341b545ff644ceccdfcfab461907050612d9d871f61591aac02ebddef9a607a9b39ce5017a2fc47c9189f85b9b9a70a30d010e4c SHA512 da771f8f334862f81702b22688c9d3552aefc2883b5a44c39156ff7a69f301cabf52fa0fb13f8695240db5411c498806d28d847fca8caff2bedb69d1a4b4e5a7
+DIST passt-2024.04.05.tar.xz 195772 BLAKE2B 4c237aeda56455f948d4309624d171612d59fa7ec653e7f89c1aeb05c677ccbdeeaaf6e14c09cda1d5bc88a97fca57dbbe480095e9711045fbd381bd30fb644a SHA512 bf14689cb1c4780d4249562965ff9a5a0515756cbf5af4b531c17982a066f33001a65210959ff8da691ddaa75560ab5691c685a4c1a4b73e742a883d12d2a24b
diff --git a/net-misc/passt/passt-2024.04.05.ebuild b/net-misc/passt/passt-2024.04.05.ebuild
new file mode 100644
index 000000000000..e4201215e520
--- /dev/null
+++ b/net-misc/passt/passt-2024.04.05.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
+HOMEPAGE="https://passt.top/"
+
+RELEASE_COMMIT="954589b"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://passt.top/passt"
+else
+ SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="static"
+
+PATCHES=(
+ "${FILESDIR}"/Makefile-2024.03.20.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ [[ ${PV} != 9999* ]] && export VERSION="${PV}"
+ export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
+
+ emake $(usev static)
+}
diff --git a/net-misc/passt/passt-9999.ebuild b/net-misc/passt/passt-9999.ebuild
index 90df839f93d9..e4201215e520 100644
--- a/net-misc/passt/passt-9999.ebuild
+++ b/net-misc/passt/passt-9999.ebuild
@@ -8,7 +8,7 @@ inherit toolchain-funcs
DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
HOMEPAGE="https://passt.top/"
-RELEASE_COMMIT="4988e2b"
+RELEASE_COMMIT="954589b"
if [[ ${PV} == 9999* ]]; then
inherit git-r3