summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-12-20 11:33:31 -0500
committerMike Gilbert <floppym@gentoo.org>2016-12-20 11:33:31 -0500
commit1b481d5086d9612b10c46d6e37cd3f733583ecea (patch)
tree0c41a70ed810bea624bf31c8122abf260de18dc7 /net-misc
parentdev-ml/eliom: bump to 6.1.0 and drop calendar dep. (diff)
downloadgentoo-1b481d5086d9612b10c46d6e37cd3f733583ecea.tar.gz
gentoo-1b481d5086d9612b10c46d6e37cd3f733583ecea.tar.bz2
gentoo-1b481d5086d9612b10c46d6e37cd3f733583ecea.zip
net-misc/libreswan: remove old
Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/libreswan/Manifest1
-rw-r--r--net-misc/libreswan/libreswan-3.17.ebuild99
2 files changed, 0 insertions, 100 deletions
diff --git a/net-misc/libreswan/Manifest b/net-misc/libreswan/Manifest
index 227effa4ca28..39cc9c8a0701 100644
--- a/net-misc/libreswan/Manifest
+++ b/net-misc/libreswan/Manifest
@@ -1,2 +1 @@
-DIST libreswan-3.17.tar.gz 9168223 SHA256 28c286f57f6d8d00e1502ea283aac0f9f863edb2d759e50dc89df0e28c0d0d03 SHA512 4503ae82663f060f3af3fd74491ae94feb33a28f13f96cd04bb4a83bba17fe199f4ff7cba83850235829b373f803ba816d7a4199d4afb1da191c7323dd28a362 WHIRLPOOL c771218d7c0a26041bb946c2805f581086e9beae8827c2fbaad49eb032107f322316e6102b3161db014d1d6e5e222d682d23a1ac147ae65fc37b0c364440cbdc
DIST libreswan-3.18.tar.gz 8766228 SHA256 2ff61178913287567ed2736287df47e7f9a822ddcded967f3af5f03e95b5f17d SHA512 dfc831ae82814a26cac2eb7c8bef4385d8aebb1e62c63f31e0997d49fc6bbcc6e4e2bcd0e07d5c0c1347e5eaca5f6eb1fba98395bc882ab0fddb804a524b57f8 WHIRLPOOL 73ce41988d62d6702837d9ba6c2e123aad678b6d983711e6e5d3a60046bdbf2a37d8f650a8e4ffff24c551a27d50ecbef322bc40a083b852a142b2a5bcda2726
diff --git a/net-misc/libreswan/libreswan-3.17.ebuild b/net-misc/libreswan/libreswan-3.17.ebuild
deleted file mode 100644
index 9cae013c203c..000000000000
--- a/net-misc/libreswan/libreswan-3.17.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit systemd toolchain-funcs
-
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://download.libreswan.org/${P}.tar.gz"
- KEYWORDS="amd64 ~ppc x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/libreswan/libreswan.git"
-fi
-
-DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
-HOMEPAGE="https://libreswan.org/"
-
-LICENSE="GPL-2 BSD-4 RSA DES"
-SLOT="0"
-IUSE="caps curl dnssec ldap pam"
-
-COMMON_DEPEND="
- dev-libs/gmp:0=
- dev-libs/libevent:0=
- dev-libs/nspr
- caps? ( sys-libs/libcap-ng )
- curl? ( net-misc/curl )
- dnssec? ( net-dns/unbound net-libs/ldns )
- ldap? ( net-nds/openldap )
- pam? ( sys-libs/pam )
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.1.2
- app-text/xmlto
- dev-libs/nss
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}
- dev-libs/nss[utils(+)]
- sys-apps/iproute2
- !net-misc/openswan
- !net-misc/strongswan
-"
-
-usetf() {
- usex "$1" true false
-}
-
-src_configure() {
- tc-export AR CC
- export INC_USRLOCAL=/usr
- export INC_MANDIR=share/man
- export FINALEXAMPLECONFDIR=/usr/share/doc/${PF}
- export FINALDOCDIR=/usr/share/doc/${PF}/html
- export INITSYSTEM=openrc
- export INC_RCDIRS=
- export INC_RCDEFAULT=/etc/init.d
- export USERCOMPILE=
- export USERLINK=
- export USE_DNSSEC=$(usetf dnssec)
- export USE_LIBCAP_NG=$(usetf caps)
- export USE_LIBCURL=$(usetf curl)
- export USE_LDAP=$(usetf ldap)
- export USE_XAUTHPAM=$(usetf pam)
- export DEBUG_CFLAGS=
- export OPTIMIZE_CFLAGS=
- export WERROR_CFLAGS=
-}
-
-src_compile() {
- emake all
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- echo "include /etc/ipsec.d/*.secrets" > "${D}"/etc/ipsec.secrets
- fperms 0600 /etc/ipsec.secrets
-
- systemd_dounit "${FILESDIR}/ipsec.service"
-
- dodoc CHANGES README
- dodoc -r docs
-
- find "${D}" -type d -empty -delete || die
-}
-
-pkg_postinst() {
- local IPSEC_CONFDIR=${ROOT%/}/etc/ipsec.d
- if [[ ! -f ${IPSEC_CONFDIR}/cert8.db ]]; then
- ebegin "Setting up NSS database in ${IPSEC_CONFDIR}"
- certutil -N -d "${IPSEC_CONFDIR}" -f <(echo)
- eend $?
- fi
-}