summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-23 19:55:17 +0000
committerSam James <sam@gentoo.org>2024-11-23 19:55:17 +0000
commit01cc487db24aae84e6db7997a234e46335b8e105 (patch)
treec311495d90d127cb96684ae05f6e4901ba8ba952 /net-misc
parentapp-misc/fastfetch: Stabilize 2.28.0 arm64, #944754 (diff)
downloadgentoo-01cc487db24aae84e6db7997a234e46335b8e105.tar.gz
gentoo-01cc487db24aae84e6db7997a234e46335b8e105.tar.bz2
gentoo-01cc487db24aae84e6db7997a234e46335b8e105.zip
net-misc/streamlink: add 7.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-7.0.0.ebuild76
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild1
3 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 2b414e1aa049..d88c7c1c490d 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,3 +1,4 @@
DIST streamlink-6.10.0.tar.gz 759416 BLAKE2B 384d943ff22bc1b351f46022bee99f3749bde48a5af40bb61707bdb26052ec41bd28e76c87dfd9f25c3b279541735dd978cdb75e69dae7cdc0821d7727b1b600 SHA512 39142c01d973a5be76f25fe711f1f36ad2581a0bab0265bc91d44644764b1c15f076809663bc821fd20ced282f5c185af2b6a5b91c12febda82dc03d000c6522
DIST streamlink-6.11.0.tar.gz 763094 BLAKE2B 7fb0a84088991bc5a7514e0a40d5c05d3a14da5cffbcb255c5e5767fcae8c745a6397cbe79b0b0fd5bebab32b0d8d6c015931af03e6eaa199b5ed9437d0f3a7e SHA512 e6d6e49d2df0aa76ebca76c0b3ada085eac59553423a5ccaa3d5cb62f6be0a679da36c4f78a3e1fea48b22144e705b8de9e46fc146c1c93889ef0c056d59fc7b
DIST streamlink-6.9.0.tar.gz 758696 BLAKE2B 14baa37903c4b3084206a59959e47e5c764603da24084361b76a21d013b833ecb49df7d6baa45eb93f3491469deda828553439cc91a0ba6af07f96ce92c13764 SHA512 7ace33553dfdf7e45642347cc468c746ef9a7e400cd5629e326a93d5c0e57d77da1538b00ebf01665f147d41e5b8cc3de241dcc0b6b1b83329ecfb46950f8d00
+DIST streamlink-7.0.0.tar.gz 765957 BLAKE2B ef0d5cc402c623856c620306fa0095daf5786813021a310d79e3b5fbcc84c12a60b3f686fef669fcd33626ce58a23293b1015f53e4a82bfb48b8b1bbcdcf160d SHA512 0d0834b19718862ac7efd16680920ec632b9c2db512c57e9eb4bc9bc6a27f7cbf0ceba557bbeb4c55a5e9680b5519961e526209ccc4b8499273daaf1cd837e4f
diff --git a/net-misc/streamlink/streamlink-7.0.0.ebuild b/net-misc/streamlink/streamlink-7.0.0.ebuild
new file mode 100644
index 000000000000..38bb73a0d640
--- /dev/null
+++ b/net-misc/streamlink/streamlink-7.0.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+# >= 6.2.1 uses a bunch of setuptools hooks instead of vanilla setuptools
+# https://github.com/streamlink/streamlink/commit/194d9bc193f5285bc1ba33af5fd89209a96ad3a7
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+# See https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358 for chardet/charset-normalizer dep
+RDEPEND="
+ media-video/ffmpeg
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.10)
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ || (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ )
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/pysocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/setuptools-64[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+if [[ ${PV} == 9999* ]]; then
+ RDEPEND+="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+ "
+fi
+
+distutils_enable_tests pytest
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 38bb73a0d640..25e719ca00a3 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -59,6 +59,7 @@ BDEPEND="
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
test? (
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-trio[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
)