summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-06-21 15:30:52 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-07-14 10:24:24 +0300
commita8cbe0ecfc59d2c2fe2371a5c9d3f8320e31797d (patch)
treee905ad60221ea3ca07721e897e67e66e254d5882 /net-misc/wput
parentdev-python/setuptools: Move dev-python/wheel to RDEPEND (diff)
downloadgentoo-a8cbe0ecfc59d2c2fe2371a5c9d3f8320e31797d.tar.gz
gentoo-a8cbe0ecfc59d2c2fe2371a5c9d3f8320e31797d.tar.bz2
gentoo-a8cbe0ecfc59d2c2fe2371a5c9d3f8320e31797d.zip
net-misc/wput: Fix call to undeclared library function exit
Closes: https://bugs.gentoo.org/898060 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31564 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/wput')
-rw-r--r--net-misc/wput/files/wput-0.6.2_p20130413_p11-exit-not-found-musl.patch9
-rw-r--r--net-misc/wput/wput-0.6.2_p20130413_p11-r1.ebuild55
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/wput/files/wput-0.6.2_p20130413_p11-exit-not-found-musl.patch b/net-misc/wput/files/wput-0.6.2_p20130413_p11-exit-not-found-musl.patch
new file mode 100644
index 000000000000..e92fb092dbd0
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6.2_p20130413_p11-exit-not-found-musl.patch
@@ -0,0 +1,9 @@
+Bug: https://bugs.gentoo.org/898060
+--- a/src/memdbg.c
++++ b/src/memdbg.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <malloc.h>
+ #include <fcntl.h>
+ #ifndef WIN32
diff --git a/net-misc/wput/wput-0.6.2_p20130413_p11-r1.ebuild b/net-misc/wput/wput-0.6.2_p20130413_p11-r1.ebuild
new file mode 100644
index 000000000000..feeba7bfe7a1
--- /dev/null
+++ b/net-misc/wput/wput-0.6.2_p20130413_p11-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tiny program like wget, to upload files/whole directories via FTP"
+HOMEPAGE="https://wput.sourceforge.net/"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_PV=$(ver_cut 1-3)
+ SRC_URI=" mirror://debian/pool/main/w/wput/wput_${MY_PV}+git$(ver_cut 5).orig.tar.bz2"
+ SRC_URI+=" mirror://debian/pool/main/w/wput/wput_${MY_PV}+git$(ver_cut 5)-$(ver_cut 7).debian.tar.xz"
+ S="${WORKDIR}"/${PN}-${MY_PV}+git$(ver_cut 5)
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tgz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug ssl"
+
+RDEPEND="ssl? ( net-libs/gnutls:= )"
+DEPEND="${RDEPEND}"
+# Debian's patches to fix spelling means need gettext to regenerate
+# It's so common that it's not really worth the 'touch' dance to avoid it
+# or conditional patching.
+BDEPEND="sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.2_p20130413_p11-xopen_source-strdup.patch
+ "${FILESDIR}"/${PN}-0.6.2_p20130413_p11-no-compress-manpages.patch
+ "${FILESDIR}"/${PN}-0.6.2_p20130413_p11-exit-not-found-musl.patch
+)
+
+src_prepare() {
+ eapply $(sed -e "s:^:${WORKDIR}/debian/patches/:" "${WORKDIR}"/debian/patches/series)
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --enable-g-switch=no
+ --enable-nls
+
+ $(usev debug '--enable-memdbg=yes')
+ $(use_with ssl)
+ )
+
+ econf "${myconf[@]}"
+}