summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/nut-monitor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/nut-monitor')
-rw-r--r--net-misc/nut-monitor/Manifest1
-rw-r--r--net-misc/nut-monitor/files/nut-monitor-1.3-paths.patch48
-rw-r--r--net-misc/nut-monitor/files/nut-monitor-1.3-paths2.patch11
-rw-r--r--net-misc/nut-monitor/metadata.xml7
-rw-r--r--net-misc/nut-monitor/nut-monitor-1.3-r2.ebuild54
5 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/nut-monitor/Manifest b/net-misc/nut-monitor/Manifest
new file mode 100644
index 000000000000..6569ea6d70bc
--- /dev/null
+++ b/net-misc/nut-monitor/Manifest
@@ -0,0 +1 @@
+DIST nut-monitor-1.3.tar.gz 31338 RMD160 9142fbf3ba04c28dd68243d4e7accd83bc1d6e13 SHA1 53fb0926fa54f16da0555113f4da88b13e7a988e SHA256 a2e23b0372d170a9a67d55227ed4a0a6a9ae1505ad23b2004782ed9964567502
diff --git a/net-misc/nut-monitor/files/nut-monitor-1.3-paths.patch b/net-misc/nut-monitor/files/nut-monitor-1.3-paths.patch
new file mode 100644
index 000000000000..00fd0ded3d3f
--- /dev/null
+++ b/net-misc/nut-monitor/files/nut-monitor-1.3-paths.patch
@@ -0,0 +1,48 @@
+--- a/scripts/python/app/NUT-Monitor
++++ b/scripts/python/app/NUT-Monitor
+@@ -70,7 +70,7 @@
+ ( cmd_opts, args ) = opt_parser.parse_args()
+
+
+- self.__glade_file = os.path.join( os.path.dirname( sys.argv[0] ), "gui-1.3.glade" )
++ self.__glade_file = '/usr/share/nut-monitor/gui-1.3.glade'
+
+ self.__widgets["interface"] = gtk.glade.XML( self.__glade_file, "window1", APP )
+ self.__widgets["main_window"] = self.__widgets["interface"].get_widget("window1")
+@@ -103,11 +103,11 @@
+
+ # Create the tray icon and connect it to the show/hide method...
+ self.__widgets["status_icon"] = gtk.StatusIcon()
+- self.__widgets["status_icon"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "on_line.png" ) )
++ self.__widgets["status_icon"].set_from_file( "/usr/share/nut-monitor/pixmaps/on_line.png" )
+ self.__widgets["status_icon"].set_visible( True )
+ self.__widgets["status_icon"].connect( "activate", self.tray_activated )
+
+- self.__widgets["ups_status_image"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "on_line.png" ) )
++ self.__widgets["ups_status_image"].set_from_file( "/usr/share/nut-monitor/pixmaps/on_line.png" )
+
+ # Define interface callbacks actions
+ self.__callbacks = { "on_window1_destroy" : self.quit,
+@@ -265,8 +265,8 @@
+ #-------------------------------------------------------------------
+ # Change the status icon and tray icon
+ def change_status_icon( self, icon="on_line", blink=False ) :
+- self.__widgets["status_icon"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "%s.png" % icon ) )
+- self.__widgets["ups_status_image"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "%s.png" % icon ) )
++ self.__widgets["status_icon"].set_from_file( "/usr/share/nut-monitor/pixmaps/%s.png" % icon )
++ self.__widgets["ups_status_image"].set_from_file( "/usr/share/nut-monitor/pixmaps/%s.png" % icon )
+ self.__widgets["status_icon"].set_blinking( blink )
+
+ #-------------------------------------------------------------------
+@@ -719,9 +719,9 @@
+
+ for k,v in vars.iteritems() :
+ if ( rwvars.has_key( k ) ) :
+- icon_file = os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "var-rw.png" )
++ icon_file = "/usr/share/nut-monitor/pixmaps/var-rw.png"
+ else :
+- icon_file = os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "var-ro.png" )
++ icon_file = "/usr/share/nut-monitor/pixmaps/var-ro.png"
+
+ icon = gtk.gdk.pixbuf_new_from_file( icon_file )
+ self.__widgets["ups_vars_tree_store"].append( [ icon, k, v ] )
diff --git a/net-misc/nut-monitor/files/nut-monitor-1.3-paths2.patch b/net-misc/nut-monitor/files/nut-monitor-1.3-paths2.patch
new file mode 100644
index 000000000000..92d6833ee1ff
--- /dev/null
+++ b/net-misc/nut-monitor/files/nut-monitor-1.3-paths2.patch
@@ -0,0 +1,11 @@
+--- NUT-Monitor~ 2012-04-03 12:04:09.000000000 +0200
++++ NUT-Monitor 2012-04-03 12:05:32.949730947 +0200
+@@ -888,7 +888,7 @@
+
+ # Init the localisation
+ APP = "NUT-Monitor"
+- DIR = "locale"
++ DIR = "/usr/share/locale"
+
+ gettext.bindtextdomain( APP, DIR )
+ gettext.textdomain( APP )
diff --git a/net-misc/nut-monitor/metadata.xml b/net-misc/nut-monitor/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/net-misc/nut-monitor/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/nut-monitor/nut-monitor-1.3-r2.ebuild b/net-misc/nut-monitor/nut-monitor-1.3-r2.ebuild
new file mode 100644
index 000000000000..2e430a9de4ca
--- /dev/null
+++ b/net-misc/nut-monitor/nut-monitor-1.3-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="A graphical application to monitor and manage UPSes connected to a NUT server"
+HOMEPAGE="http://www.lestat.st/informatique/projets/nut-monitor-en/"
+SRC_URI="http://www.lestat.st/_media/informatique/projets/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_fr"
+
+RDEPEND="dev-python/pygtk
+ dev-python/pynut"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-paths.patch
+ epatch "${FILESDIR}"/${P}-paths2.patch
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ dobin NUT-Monitor
+ dosym NUT-Monitor /usr/bin/${PN}
+
+ insinto /usr/share/nut-monitor
+ doins gui-${PV}.glade
+
+ dodir /usr/share/nut-monitor/pixmaps
+ insinto /usr/share/nut-monitor/pixmaps
+ doins pixmaps/*
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+
+ dodoc README
+
+ if use linguas_fr; then
+ insinto /usr/share/locale/fr/LC_MESSAGES/
+ doins locale/fr/LC_MESSAGES/NUT-Monitor.mo
+ fi
+}