summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 00:28:29 -0500
committerSam James <sam@gentoo.org>2024-02-29 05:44:22 +0000
commitd75e15958f8afbe0da714fcec426bcc2fce8b90e (patch)
treea731e17801c8b2ecba871b98604c200f2bf4766b /net-misc/kea
parentnet-print/hplip: mark as LTO-unsafe (diff)
downloadgentoo-d75e15958f8afbe0da714fcec426bcc2fce8b90e.tar.gz
gentoo-d75e15958f8afbe0da714fcec426bcc2fce8b90e.tar.bz2
gentoo-d75e15958f8afbe0da714fcec426bcc2fce8b90e.zip
net-misc/kea: mark as LTO-unsafe
No upstream bug report. I tried. They won't let me create an account: ``` 1 error prohibited this user from being saved: Email is not allowed for sign-up. Please use your regular email address. Check with your administrator. ``` Closes: https://bugs.gentoo.org/861617 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/kea')
-rw-r--r--net-misc/kea/kea-2.4.0-r1.ebuild9
-rw-r--r--net-misc/kea/kea-2.4.1.ebuild9
-rw-r--r--net-misc/kea/kea-9999.ebuild11
3 files changed, 25 insertions, 4 deletions
diff --git a/net-misc/kea/kea-2.4.0-r1.ebuild b/net-misc/kea/kea-2.4.0-r1.ebuild
index 7227b2d84c1d..72c97487d6f6 100644
--- a/net-misc/kea/kea-2.4.0-r1.ebuild
+++ b/net-misc/kea/kea-2.4.0-r1.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://www.isc.org/kea/"
PYTHON_COMPAT=( python3_{8..12} )
-inherit autotools fcaps python-single-r1 systemd tmpfiles
+inherit autotools fcaps flag-o-matic python-single-r1 systemd tmpfiles
if [[ ${PV} = 9999* ]] ; then
inherit git-r3
@@ -90,6 +90,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/861617
+ #
+ # I would truly love to submit an upstream bug but their self-hosted gitlab
+ # won't let me sign up. -- Eli
+ filter-lto
+
local myeconfargs=(
--disable-install-configurations
--disable-rpath
diff --git a/net-misc/kea/kea-2.4.1.ebuild b/net-misc/kea/kea-2.4.1.ebuild
index 7227b2d84c1d..72c97487d6f6 100644
--- a/net-misc/kea/kea-2.4.1.ebuild
+++ b/net-misc/kea/kea-2.4.1.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://www.isc.org/kea/"
PYTHON_COMPAT=( python3_{8..12} )
-inherit autotools fcaps python-single-r1 systemd tmpfiles
+inherit autotools fcaps flag-o-matic python-single-r1 systemd tmpfiles
if [[ ${PV} = 9999* ]] ; then
inherit git-r3
@@ -90,6 +90,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/861617
+ #
+ # I would truly love to submit an upstream bug but their self-hosted gitlab
+ # won't let me sign up. -- Eli
+ filter-lto
+
local myeconfargs=(
--disable-install-configurations
--disable-rpath
diff --git a/net-misc/kea/kea-9999.ebuild b/net-misc/kea/kea-9999.ebuild
index bf1c596ab6ba..2c411fe395c2 100644
--- a/net-misc/kea/kea-9999.ebuild
+++ b/net-misc/kea/kea-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ HOMEPAGE="https://www.isc.org/kea/"
PYTHON_COMPAT=( python3_{8..12} )
-inherit autotools fcaps python-single-r1 systemd tmpfiles
+inherit autotools fcaps flag-o-matic python-single-r1 systemd tmpfiles
if [[ ${PV} = 9999* ]] ; then
inherit git-r3
@@ -86,6 +86,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/861617
+ #
+ # I would truly love to submit an upstream bug but their self-hosted gitlab
+ # won't let me sign up. -- Eli
+ filter-lto
+
local myeconfargs=(
--disable-install-configurations
--disable-rpath