summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-11 22:59:06 +0000
committerSam James <sam@gentoo.org>2022-12-11 22:59:06 +0000
commitbc57bee3e73decce0bce78f3636228969749b1cc (patch)
tree2d3e98d395f4372d280246667ae71289c47a8a9c /net-misc/curl
parentnet-misc/curl: add rustls support (diff)
downloadgentoo-bc57bee3e73decce0bce78f3636228969749b1cc.tar.gz
gentoo-bc57bee3e73decce0bce78f3636228969749b1cc.tar.bz2
gentoo-bc57bee3e73decce0bce78f3636228969749b1cc.zip
net-misc/curl: pass --without-rustls if not enabled
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/curl-7.86.0-r3.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/net-misc/curl/curl-7.86.0-r3.ebuild b/net-misc/curl/curl-7.86.0-r3.ebuild
index c66e10b796b0..fb34199c73a2 100644
--- a/net-misc/curl/curl-7.86.0-r3.ebuild
+++ b/net-misc/curl/curl-7.86.0-r3.ebuild
@@ -120,7 +120,7 @@ multilib_src_configure() {
myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
#myconf+=( --without-default-ssl-backend )
if use ssl ; then
- myconf+=( --without-gnutls --without-mbedtls --without-nss )
+ myconf+=( --without-gnutls --without-mbedtls --without-nss --without-rustls )
if use gnutls || use curl_ssl_gnutls; then
einfo "SSL provided by gnutls"