summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-11-30 09:12:42 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2024-11-30 09:21:45 -0800
commite888db52017440217e454dc2cee400bb5cfaa194 (patch)
tree09efc21374fa9ad0faa93a1fc8d9388c01394ef1 /net-mail
parentdev-python/zc-lockfile: Stabilize 3.0_p1 sparc, #936753 (diff)
downloadgentoo-e888db52017440217e454dc2cee400bb5cfaa194.tar.gz
gentoo-e888db52017440217e454dc2cee400bb5cfaa194.tar.bz2
gentoo-e888db52017440217e454dc2cee400bb5cfaa194.zip
net-mail/safecat: fixes for modern compilers
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/show_bug.cgi?id=929081 Closes: https://bugs.gentoo.org/show_bug.cgi?id=934407
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/safecat/Manifest1
-rw-r--r--net-mail/safecat/safecat-1.13-r2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-mail/safecat/Manifest b/net-mail/safecat/Manifest
index e2c2234a9cf0..964b1daf5af0 100644
--- a/net-mail/safecat/Manifest
+++ b/net-mail/safecat/Manifest
@@ -1 +1,2 @@
+DIST safecat-1.13-clang-fixes.patch 36070 BLAKE2B bbf7157c2546626fe22d76b0b08596473fe51f880a7abe5ce6c554e88dd4f7f510c719cf3357716d5cece9a50b4be7dbbfb525985ae08d4b8b2a9c5c45698981 SHA512 7c59bfa4101c8ff43e97467b2699c3de07f763e304c3a2c4742516a107490f2fdfce64cde797ade66766d1c01b02f31eeaaeb3d6cc2f743a0d200ad0384f3d34
DIST safecat-1.13.tar.gz 33953 BLAKE2B d8b4132b530f975fb5629bc591e3b332cd6c8c29684a8848e76b7a660a6ea683adc8b89b92fbe37cf5c1236bca597d9ec6e44bfb5b35076a98d6590f355a40ae SHA512 e6f7401b55a61f70715b3d222c8286c0125c5e7b3b132e5e8d3c8573a6c45dba75b29a459c7e93d7c0760300f0a62635d8ea4eacde9b0b1ff7637b3f6c63e210
diff --git a/net-mail/safecat/safecat-1.13-r2.ebuild b/net-mail/safecat/safecat-1.13-r2.ebuild
new file mode 100644
index 000000000000..d74f17778cea
--- /dev/null
+++ b/net-mail/safecat/safecat-1.13-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Safecat implements qmail's maildir algorithm, safely copying standard input"
+HOMEPAGE="http://www.jeenyus.net/linux/software/safecat.html"
+SRC_URI="http://www.jeenyus.net/linux/software/${PN}/${P}.tar.gz"
+SRC_URI+=" mirror://gentoo/${P}-clang-fixes.patch"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+RESTRICT="test"
+
+DEPEND="sys-apps/groff"
+
+PATCHES=(
+ # applying maildir-patch
+ "${FILESDIR}"/safecat-1.11-gentoo.patch
+ # Fix parallel make errors
+ "${FILESDIR}"/${P}-makefile.patch
+ # Fix POSIX head/tail syntax
+ "${FILESDIR}"/${P}-head-tail-POSIX.patch
+ # Fix dup objects
+ "${FILESDIR}"/${P}-dup-obj-makefile.patch
+ # Headers
+ "${FILESDIR}"/${P}-include.patch
+ # Clang fixes
+ "${DISTDIR}"/${P}-clang-fixes.patch
+)
+
+src_prepare() {
+ default
+
+ sed -ni '/man\|doc/!p' hier.c || die
+}
+
+src_configure() {
+ echo "/usr" > conf-root || die
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+ echo "$(tc-getAR)" > conf-ar || die
+}
+
+src_install() {
+ # ${D} is not valid in src_configure
+ # Do not use DJB compiled installer anymore
+ #echo "${D}/usr" > conf-root || die
+ #emake setup check
+ dobin safecat maildir
+ einstalldocs
+ doman maildir.1 safecat.1
+}