summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-09-19 10:59:32 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-12-11 15:01:34 +0200
commitdc84a57f23f427c7b560bcdb3f28f9364a995456 (patch)
treecd6e55d7176040b121a721797ca58ea77e544635 /net-mail
parentsys-kernel/pf-sources: add 6.6_p4 (diff)
downloadgentoo-dc84a57f23f427c7b560bcdb3f28f9364a995456.tar.gz
gentoo-dc84a57f23f427c7b560bcdb3f28f9364a995456.tar.bz2
gentoo-dc84a57f23f427c7b560bcdb3f28f9364a995456.zip
net-mail/asmail: revbump, fix clang16 bugs
Closes: https://bugs.gentoo.org/877115 Closes: https://bugs.gentoo.org/900170 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/32921 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/asmail/asmail-2.1-r3.ebuild57
-rw-r--r--net-mail/asmail/files/asmail-2.1-update-autotools.patch61
2 files changed, 118 insertions, 0 deletions
diff --git a/net-mail/asmail/asmail-2.1-r3.ebuild b/net-mail/asmail/asmail-2.1-r3.ebuild
new file mode 100644
index 000000000000..c417c16fb169
--- /dev/null
+++ b/net-mail/asmail/asmail-2.1-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A small mail monitor similar to xbiff"
+HOMEPAGE="https://tigr.net/afterstep/applets/"
+SRC_URI="https://tigr.net/afterstep/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="jpeg"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-libs/libSM
+ jpeg? ( media-libs/libjpeg-turbo:0 )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-update-autotools.patch
+)
+
+src_prepare() {
+ default
+ cd "${S}/autoconf"
+ eautoreconf
+ cp "${S}/autoconf/configure" "${S}/" || die
+}
+
+src_configure() {
+ tc-export CC
+ econf $(use_enable jpeg) --with-xpm-library=/usr/$(get_libdir)
+}
+
+src_install() {
+ dobin ${PN}
+
+ newman ${PN}.man ${PN}.1
+ newman ${PN}rc.man ${PN}rc.5
+
+ insinto /usr/share/${PN}/pixmaps
+ doins pixmaps/cloud-e/*.xpm
+
+ insinto /usr/share/${PN}
+ doins -r sounds
+
+ dodoc ${PN}rc.s* CHANGES *.txt README* TODO
+}
diff --git a/net-mail/asmail/files/asmail-2.1-update-autotools.patch b/net-mail/asmail/files/asmail-2.1-update-autotools.patch
new file mode 100644
index 000000000000..287b36480111
--- /dev/null
+++ b/net-mail/asmail/files/asmail-2.1-update-autotools.patch
@@ -0,0 +1,61 @@
+I order to compile this package with clang we need to run autoreconf. Newer autotools complain about
+the several declarations of the same header.
+
+MD5 calculation is split from libssl into libcrypto.
+
+Bug: https://bugs.gentoo.org/880913
+Bug: https://bugs.gentoo.org/900170
+
+--- a/autoconf/Makefile.defines.in
++++ b/autoconf/Makefile.defines.in
+@@ -38,7 +38,8 @@ LIBS_XEXTS =
+ LIBS_AFTERSTEP = -lXt
+ LIBS_PTHREAD = -lpthread -lrt
+ LIBS_SSL = @HAVESSL@
+-LIBRARIES = $(LIBS_X) $(LIBS_XPM) $(LIBS_XEXTS) $(LIBS_PTHREAD) $(LIBS_SSL)
++LIBS_CRYPTO = @HAVECRYPTO@
++LIBRARIES = $(LIBS_X) $(LIBS_XPM) $(LIBS_XEXTS) $(LIBS_PTHREAD) $(LIBS_SSL) $(LIBS_CRYPTO)
+
+ AFTER_BIN_DIR = @bindir@
+ AFTER_MAN_DIR = @mandir@/man1
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -1,3 +1,4 @@
++
+ dnl# -*- sh -*-
+ dnl# Process this file with autoconf to produce a configure script.
+ dnl#
+@@ -61,7 +62,6 @@ AC_CHECK_HEADERS(sys/statvfs.h sys/vfs.h sys/mount.h ustat.h)
+ AC_CHECK_HEADERS(machine/soundcard.h linux/soundcard.h linux/radio.h)
+ AC_CHECK_HEADERS(pthread.h)
+ AC_CHECK_HEADERS(openssl/ssl.h)
+-AC_CONFIG_HEADER(config.h)
+
+ dnl# Check for X
+
+@@ -110,8 +110,12 @@ AC_CHECK_LIB(ssl, SSL_CTX_new, [SSL_LIB="-lssl" HAVESSL="-lssl"],,)
+ MD5_OBJ=""
+ if test "x$HAVESSL" = "x"; then
+ MD5_OBJ="md5c.o"
++else
++ AC_CHECK_HEADERS(openssl/md5.h)
+ fi
+
++AC_CHECK_LIB(crypto, MD5, [CRYPTO_LIB="-lcrypto" HAVECRYPTO="-lcrypto"],,)
++
+ dnl# Variable strings declaration
+
+ AC_SUBST(version)
+@@ -129,11 +133,10 @@ AC_SUBST(with_gnustep_lib)
+ AC_SUBST(with_afterdir)
+ AC_SUBST(HAVESSL)
+ AC_SUBST(MD5_OBJ)
++AC_SUBST(HAVECRYPTO)
+
+ dnl# Write results
+
+-AC_CONFIG_HEADER(config.h)
+-
+ dnl# Common parts of the Makefile
+ MAKEFILEDEFINES=./autoconf/Makefile.defines
+ MAKEFILECOMMON=./autoconf/Makefile.common