summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-03-05 07:51:51 -0500
committerAnthony G. Basile <blueness@gentoo.org>2020-03-05 07:52:01 -0500
commit9ca2c72de7a9714230e068eb69c28da82bb5004c (patch)
treeb01f6e1989e66884d4862f2f64c4f73ff3a8a5ff /net-libs
parentdev-python/freezegun: arm stable wrt bug #711504 (diff)
downloadgentoo-9ca2c72de7a9714230e068eb69c28da82bb5004c.tar.gz
gentoo-9ca2c72de7a9714230e068eb69c28da82bb5004c.tar.bz2
gentoo-9ca2c72de7a9714230e068eb69c28da82bb5004c.zip
net-libs/libmicrohttpd: version bump to 0.9.70
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.70.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index e7f22568c7df..745d22909650 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -1,3 +1,4 @@
DIST libmicrohttpd-0.9.65.tar.gz 1633346 BLAKE2B ce6ba2b6c52e30194872c66ab5b9e358f0979dd99ef24ce59fddf9e6fc2b76b01f424f9c9b511cf88c2dde2ca98d3f6a25cbcd26bdfadf0b9db65efd36435dc7 SHA512 751b7a5970cef07f260660254bfdeda4882e9e28d5cbdfbfed50e2c4583caf8f19c96ede6d368babc4223e7fbdf85d85eec37dc96abf333377dc13d6a9c6be12
DIST libmicrohttpd-0.9.68.tar.gz 1884342 BLAKE2B 3f74c48917fa19753a617242fa07b99a69510a14a802609d038964d927516f8f52b4330d0eee2c7b98096b2d840158e4945310edef290224ea256d9616fb4d94 SHA512 9daaab5fb35fef6f2a19b7e08eeb8473aeb0a67631808a8d7a7f78a09cb621ca5d32dbbbca616865a40afb92f8c6495f9e2ba1674880af8011a2bc798c070a13
DIST libmicrohttpd-0.9.69.tar.gz 1884511 BLAKE2B 6470b52e58d82a7fee17d8545e546cb9d3fa38012bcf3380d238afdf0f1b5391e19df53a89ac977ac9452d23610dc851f5da5972cace8d8f1088e1040d173572 SHA512 1633d2e606f476489e8af549fff88735e3b5641c85d59071edc8b2e1177fe1b6302578b69b8ff6669d3e1954c20cf0fa1ee52b42378362edd26197d8992e469b
+DIST libmicrohttpd-0.9.70.tar.gz 1886435 BLAKE2B 09ae33c66f151d9ce03b8333b26c32e2c0896d150441f39da632fe1316c66123f343d021d7fc9a974fbbab7e642d253138d071d4ee506477de46bffd3ce4691c SHA512 391293688d5ef51cf8d918294000384cb291f46bf767295af5a97123c06c75573d480a6c4b2486712b53636fe3e5dc1f8827ccf4335ac435ec85c3529733d8f5
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.70.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.70.ebuild
new file mode 100644
index 000000000000..63a50da01def
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.70.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+epoll ssl static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}