summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-02 12:11:41 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-02 12:11:54 +0100
commit417647917e6d12ad0c0dbeb95b9536945d29d96f (patch)
tree8844a3242f0a1779d97722c34ea579522d1033d8 /net-libs
parentapp-text/stardict: remove old (diff)
downloadgentoo-417647917e6d12ad0c0dbeb95b9536945d29d96f.tar.gz
gentoo-417647917e6d12ad0c0dbeb95b9536945d29d96f.tar.bz2
gentoo-417647917e6d12ad0c0dbeb95b9536945d29d96f.zip
net-libs/liblockfile: Bump to version 1.10
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/liblockfile/Manifest1
-rw-r--r--net-libs/liblockfile/liblockfile-1.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/liblockfile/Manifest b/net-libs/liblockfile/Manifest
index 6a0458b09b61..3d663478dffb 100644
--- a/net-libs/liblockfile/Manifest
+++ b/net-libs/liblockfile/Manifest
@@ -1 +1,2 @@
DIST liblockfile_1.09.orig.tar.gz 32178 SHA256 16979eba05396365e1d6af7100431ae9d32f9bc063930d1de66298a0695f1b7f SHA512 8577f8bfa9c78983d6a409bc449be0d981e599a6a5f2fc8b43f76a238810ec5e3c180e27280719398f31041ed837fe8ba61df208ce77db77a354453e4579848a WHIRLPOOL 4365bd4f90207a97ec8421f60bcf2d61c4565eecc9435fd920b31ede3e182856783d21ad466632ea8d18e0378f3401637185235ef90e50d6bc10d093ae4d8a42
+DIST liblockfile_1.10.orig.tar.gz 43617 SHA256 f58db53e4b558734bf7f33f96085d803126bdde2a434cd01eeface42a5539b2c SHA512 fa38d16d7af787ca47d6adaa87abb50af0ec1d4ae9d6e7eb8e77f58c44e974dc99a79bd648ded4f539b00540a513d8e40742b706b242365f3ffdf0cf392f618d WHIRLPOOL 4cb36e31eb1454ed8d78ca47926737c4bccb1152e66273d1097ae354d8f67cbde6bc987ff5bef5fb202425c9641cc7c762ceaf6c640adff5daca59d61dded0f1
diff --git a/net-libs/liblockfile/liblockfile-1.10.ebuild b/net-libs/liblockfile/liblockfile-1.10.ebuild
new file mode 100644
index 000000000000..79e62cda3c71
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib user
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+pkg_setup() {
+ enewgroup mail 12
+}
+
+src_prepare() {
+ default
+
+ # I don't feel like making the Makefile portable
+ [[ ${CHOST} == *-darwin* ]] \
+ && cp "${FILESDIR}"/Makefile.Darwin.in Makefile.in
+
+ eautoreconf
+}
+
+src_configure() {
+ local grp=mail
+ if use prefix ; then
+ # we never want to use LDCONFIG
+ export LDCONFIG=${EPREFIX}/bin/true
+ # in unprivileged installs this is "mail"
+ grp=$(id -g)
+ fi
+ econf --with-mailgroup=${grp} --enable-shared
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ emake ROOT="${D}" install
+ dodoc README Changelog
+}