summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-03-02 23:26:53 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-03-03 00:03:02 +0100
commit03eed7d4c3ed773e58f35ecd7db0dbb5a5679dc6 (patch)
treede6045862f503b60536aec2bda59c19e9130882b /net-libs
parentapp-misc/recoll: crank copyright (diff)
downloadgentoo-03eed7d4c3ed773e58f35ecd7db0dbb5a5679dc6.tar.gz
gentoo-03eed7d4c3ed773e58f35ecd7db0dbb5a5679dc6.tar.bz2
gentoo-03eed7d4c3ed773e58f35ecd7db0dbb5a5679dc6.zip
net-libs/nghttp2: add 1.60.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.60.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index d803d2b1e553..cc4bf906855b 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.57.0.tar.xz 1543568 BLAKE2B 6fad0f922477f896db14319433569b99cf599217335b5af189cc7b460f78996a801845927040d4f529151bbcc572b2cf4d8d28eae2647fad1fd35f796fd4afb8 SHA512 d914eb48afd1ea182c1b2a454bf5e7963a7e28165f1d6d29bb83dd61a1b611c8c469e72a7a22daf23b8037f6e5ae9d4e791150b7d135746c1a5ec71ceb777f92
DIST nghttp2-1.58.0.tar.xz 1546332 BLAKE2B db51bf6a0307f1465f4fcda7555b3a720800ee09aa8d26533fb6726f9b56a137435f5ea745f8fa5f927c8638e2a8fd371b04825e23c6a802070cebcfb654d256 SHA512 97b70727c633be1168df6a5b48617dde113b1d1e34176ec8bf22f4449041af2f73b2ada438d14336c9712271ec6bfc7525f000c8ca6a7a9f8d06db01b876dd1c
DIST nghttp2-1.59.0.tar.xz 1546956 BLAKE2B 0a1471c3686fcf8a896183e71e7a1c000e9397fc1831054dc87ab8860ff5d8ce2ec5ede0ba916edc7fcf94f3361b2f91e623303cbb1f6c08310f5bfbfe6cebfe SHA512 0725f302957520893ac454997adc6d6e71dc9b520c62390477fe8c5dd5c64d02415023266814cfec859bf562159e4a42eeb7d7312c5871739a3d57ed7430820b
+DIST nghttp2-1.60.0.tar.xz 1587004 BLAKE2B 8f2ab1aead261823fd2b15e54f0404c118a13f269c0f1c5d2cdc3f344e35338bcf64acfe58bed8ffbcda3843935c7168650dfc8bef17c1cdfacb684261bb2727 SHA512 5e6365d9118596d41848930de70f4a918d72463920184df60a7e1678c3a6c9cf1416236888e7e34395c87f41bba00a114994ba5a6e73f6a389769abf1b5cc842
diff --git a/net-libs/nghttp2/nghttp2-1.60.0.ebuild b/net-libs/nghttp2/nghttp2-1.60.0.ebuild
new file mode 100644
index 000000000000..4b3b74750dc6
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.60.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/1.14" # 1.<SONAME>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug hpack-tools jemalloc static-libs systemd test utils xml"
+
+RESTRICT="!test? ( test )"
+
+SSL_DEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist(-),${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ hpack-tools? ( >=dev-libs/jansson-2.5:= )
+ jemalloc? ( dev-libs/jemalloc:=[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ systemd? ( >=sys-apps/systemd-209 )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_FAILMALLOC=OFF
+ -DENABLE_WERROR=OFF
+ -DENABLE_THREADS=ON
+ -DENABLE_DEBUG=$(usex debug)
+ -DENABLE_HPACK_TOOLS=$(multilib_native_usex hpack-tools)
+ $(cmake_use_find_package hpack-tools Jansson)
+ -DWITH_JEMALLOC=$(multilib_native_usex jemalloc)
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ $(cmake_use_find_package systemd Systemd)
+ -DENABLE_APP=$(multilib_native_usex utils)
+ -DWITH_LIBXML2=$(multilib_native_usex xml)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ eninja check
+}