summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-26 12:49:51 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-27 09:34:38 -0500
commite85481619918ebda09deae2fedf46c5ded6665f8 (patch)
tree58479e81e4934d76927ef7b4aa8c272366b6baeb /net-libs/srt/files
parentnet-misc/rclone: bump 1.44 (diff)
downloadgentoo-e85481619918ebda09deae2fedf46c5ded6665f8.tar.gz
gentoo-e85481619918ebda09deae2fedf46c5ded6665f8.tar.bz2
gentoo-e85481619918ebda09deae2fedf46c5ded6665f8.zip
net-libs/srt: 1.3.1 version bump
Closes: https://bugs.gentoo.org/671986 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/srt/files')
-rw-r--r--net-libs/srt/files/srt-1.3.1-no-rpath.patch28
-rw-r--r--net-libs/srt/files/srt-always-GNUInstallDirs.patch25
2 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/srt/files/srt-1.3.1-no-rpath.patch b/net-libs/srt/files/srt-1.3.1-no-rpath.patch
new file mode 100644
index 000000000000..6e3650709c63
--- /dev/null
+++ b/net-libs/srt/files/srt-1.3.1-no-rpath.patch
@@ -0,0 +1,28 @@
+From a90e6ab27bc20fa34536c19828db5be44be4ef4d Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Mon, 26 Nov 2018 21:51:20 -0500
+Subject: [PATCH] Do not force rpath on Linux
+
+---
+ CMakeLists.txt | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eb2582c..60c4507 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -663,14 +663,6 @@ macro(srt_make_application name)
+ # set (CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+ # set (FORCE_RPATH BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
+
+- if (LINUX)
+- # This is only needed on Linux, on Windows (including Cygwin) the library file will
+- # be placed into the binrary directory anyway.
+- # XXX not sure about Mac.
+- # See this name used already in install(${TARGET_srt} LIBRARY DESTINATION...).
+- set(FORCE_RPATH LINK_FLAGS -Wl,-rpath,.,-rpath,../${CMAKE_INSTALL_LIBDIR} BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
+- endif()
+-
+ # We state that Darwin always uses CLANG compiler, which honors this flag the same way.
+ set_target_properties(${name} PROPERTIES COMPILE_FLAGS "${CFLAGS_CXX_STANDARD} ${EXTRA_stransmit}" ${FORCE_RPATH})
+
diff --git a/net-libs/srt/files/srt-always-GNUInstallDirs.patch b/net-libs/srt/files/srt-always-GNUInstallDirs.patch
new file mode 100644
index 000000000000..94332ad44762
--- /dev/null
+++ b/net-libs/srt/files/srt-always-GNUInstallDirs.patch
@@ -0,0 +1,25 @@
+From 68190ee0db1bc7577f17c51616966f509f971b0a Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Mon, 26 Nov 2018 12:45:38 -0500
+Subject: [PATCH] Always use GNUInstallDirs
+
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eb2582c..59a41d4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,9 +32,9 @@ set_if(SYMLINKABLE LINUX OR DARWIN OR CYGWIN)
+ # inside "bin" and "lib64" directories. At least this maintains
+ # the current status. Shall this be not desired, override values
+ # of CMAKE_INSTALL_BINDIR, CMAKE_INSTALL_LIBDIR and CMAKE_INSTALL_INCLUDEDIR.
+-if (NOT DEFINED CMAKE_INSTALL_LIBDIR)
++# if (NOT DEFINED CMAKE_INSTALL_LIBDIR)
+ include(GNUInstallDirs)
+-endif()
++# endif()
+
+ set (SRT_VERSION 1.3.1)
+ set_version_variables(SRT_VERSION ${SRT_VERSION})