summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 11:17:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 15:03:37 +0100
commit5c734e9fbe789d54100072ce68408871b129b22c (patch)
treecc07291e397203223493963658097caf03495f50 /net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild
parentmedia-libs/openexr: Stabilize 2.5.5 ppc, #770229 (diff)
downloadgentoo-5c734e9fbe789d54100072ce68408871b129b22c.tar.gz
gentoo-5c734e9fbe789d54100072ce68408871b129b22c.tar.bz2
gentoo-5c734e9fbe789d54100072ce68408871b129b22c.zip
net-libs/socket_wrapper: 1.3.2 version bump, switch to cmake.eclass
Closes: https://bugs.gentoo.org/737614 Closes: https://bugs.gentoo.org/770571 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild
new file mode 100644
index 000000000000..b714f672e700
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}