summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-27 08:06:40 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-27 08:27:00 +0100
commit8490e4f1366bc3952aec241f61d72aeb07100a8b (patch)
tree431dce821f13855355ceb2bfe0c4ffbde129b85d /net-libs/libssh2/libssh2-1.7.0.ebuild
parentdev-ruby/fakefs: add 0.8.0 (diff)
downloadgentoo-8490e4f1366bc3952aec241f61d72aeb07100a8b.tar.gz
gentoo-8490e4f1366bc3952aec241f61d72aeb07100a8b.tar.bz2
gentoo-8490e4f1366bc3952aec241f61d72aeb07100a8b.zip
net-libs/libssh2: Version bump (bug #575474).
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs/libssh2/libssh2-1.7.0.ebuild')
-rw-r--r--net-libs/libssh2/libssh2-1.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libssh2/libssh2-1.7.0.ebuild b/net-libs/libssh2/libssh2-1.7.0.ebuild
new file mode 100644
index 000000000000..27e18acd42dc
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+inherit autotools-multilib
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt libressl static-libs test zlib"
+
+DEPEND="
+ !gcrypt? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ sed -i -e 's|mansyntax.sh||g' tests/Makefile.am || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ # Disable tests that require extra permissions (bug #333319)
+ use test && local -x ac_cv_path_SSHD=
+
+ local myeconfargs=(
+ $(use_with zlib libz)
+ $(usex gcrypt --with-libgcrypt --with-openssl)
+ )
+ autotools-utils_src_configure
+}