summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-03-19 23:18:05 +0000
committerAnthony G. Basile <blueness@gentoo.org>2016-03-20 11:42:55 -0400
commitd5fb469859f75c12eb5874dedcd0be3026179a1c (patch)
treee0a48073381b9d276c7cb7b36fcc857bc953d8d8 /net-libs/libbitcoinconsensus/libbitcoinconsensus-9999.ebuild
parentdev-libs/univalue: initial commit, version 1.0.2 (diff)
downloadgentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.tar.gz
gentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.tar.bz2
gentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.zip
net-p2p/bitcoin*: bump all pkgs to 0.12.0 and update 9999
Diffstat (limited to 'net-libs/libbitcoinconsensus/libbitcoinconsensus-9999.ebuild')
-rw-r--r--net-libs/libbitcoinconsensus/libbitcoinconsensus-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-libs/libbitcoinconsensus/libbitcoinconsensus-9999.ebuild b/net-libs/libbitcoinconsensus/libbitcoinconsensus-9999.ebuild
index 287ed610c271..38a8f571d0f5 100644
--- a/net-libs/libbitcoinconsensus/libbitcoinconsensus-9999.ebuild
+++ b/net-libs/libbitcoinconsensus/libbitcoinconsensus-9999.ebuild
@@ -5,6 +5,7 @@
EAPI=5
BITCOINCORE_IUSE="test"
+BITCOINCORE_NO_DEPEND="libevent"
inherit bitcoincore eutils
DESCRIPTION="Bitcoin Core consensus library"
@@ -12,6 +13,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS=""
+src_prepare() {
+ bitcoincore_src_prepare
+ epatch "${FILESDIR}/bugfix_bench_checks.patch"
+}
+
src_configure() {
bitcoincore_conf \
--with-libs