summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/konversation
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/konversation')
-rw-r--r--net-irc/konversation/Manifest2
-rw-r--r--net-irc/konversation/konversation-1.5.1.ebuild37
-rw-r--r--net-irc/konversation/konversation-1.6.ebuild64
-rw-r--r--net-irc/konversation/metadata.xml6
4 files changed, 109 insertions, 0 deletions
diff --git a/net-irc/konversation/Manifest b/net-irc/konversation/Manifest
new file mode 100644
index 000000000000..eba214e60b94
--- /dev/null
+++ b/net-irc/konversation/Manifest
@@ -0,0 +1,2 @@
+DIST konversation-1.5.1.tar.xz 3188288 SHA256 97838dc3cb07210c96154958237e216ad05cffa334f5e549d8619b4c70961986 SHA512 c34def02b776692134e40f6a6fc8a7d362a58d1365a247f21828e08a0df95aface809e23f187f7c445112ce3e8cc41826ef8558de5b224258269c67ea6826615 WHIRLPOOL 44e78a0353673401ab36f2d292e18d19305d0aede43b5b929407fc0cb9d5389816b2840e7acecd644c172eada9eee52f8bbca5d9dfa252189d57fcc646fe644a
+DIST konversation-1.6.tar.xz 3447184 SHA256 789fd75644bf54606778971310433dbe2bc01ac0917b34bc4e8cac88e204d5b6 SHA512 d159bba55d776a867934424e87d02637a135e8d091c237688b64bf0c62c738075d52f2931dbd84984e886668f2152bda6a958be8da37b5debbb795db6686197a WHIRLPOOL 96728b3701eeb94f328381e61cb7901e89f88b2e238072d398a8fe2105bd49b9b3e6e855c5fe5516d7611245821c32728d1fdbddd42233ebb9a8a04c0ad9e126
diff --git a/net-irc/konversation/konversation-1.5.1.ebuild b/net-irc/konversation/konversation-1.5.1.ebuild
new file mode 100644
index 000000000000..5444517539a4
--- /dev/null
+++ b/net-irc/konversation/konversation-1.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB es et fi fr gl he hu it ja
+kk km ko lt nb nds nl pa pl pt pt_BR ru si sk sl sr sr@ijekavian
+sr@ijekavianlatin sr@latin sv tr uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A user friendly IRC Client for KDE4"
+HOMEPAGE="http://kde.org/applications/internet/konversation/ http://konversation.kde.org"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="GPL-2 handbook? ( FDL-1.2 )"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="+crypt debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ media-libs/phonon[qt4]
+ crypt? ( app-crypt/qca:2[qt4(+)] )
+"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/qca:2[openssl] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with crypt QCA2)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/net-irc/konversation/konversation-1.6.ebuild b/net-irc/konversation/konversation-1.6.ebuild
new file mode 100644
index 000000000000..479c880b7c42
--- /dev/null
+++ b/net-irc/konversation/konversation-1.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A user friendly IRC Client"
+HOMEPAGE="http://kde.org/applications/internet/konversation/ http://konversation.kde.org"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_frameworks_dep sonnet)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/phonon[qt5]
+ crypt? ( app-crypt/qca:2[qt5] )
+ sys-devel/gettext
+"
+RDEPEND="${DEPEND}
+ !net-irc/konversation:4
+ crypt? ( app-crypt/qca:2[openssl] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ )
+
+ kde5_src_configure
+}
diff --git a/net-irc/konversation/metadata.xml b/net-irc/konversation/metadata.xml
new file mode 100644
index 000000000000..96dedda219e8
--- /dev/null
+++ b/net-irc/konversation/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+<herd>kde</herd>
+</pkgmetadata>