summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-09-15 12:58:32 +0000
committerYixun Lan <dlan@gentoo.org>2023-09-15 12:58:32 +0000
commit2a9a8e0fed2a48d1446055eb71388f64bf45c699 (patch)
tree472f5852e3269bfa2c9264c3665eef207c28cbe6 /net-im/slack
parentwww-apps/jackett: drop 0.21.747 (diff)
downloadgentoo-2a9a8e0fed2a48d1446055eb71388f64bf45c699.tar.gz
gentoo-2a9a8e0fed2a48d1446055eb71388f64bf45c699.tar.bz2
gentoo-2a9a8e0fed2a48d1446055eb71388f64bf45c699.zip
net-im/slack: add 4.34.120
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-im/slack')
-rw-r--r--net-im/slack/Manifest1
-rw-r--r--net-im/slack/slack-4.34.120.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/net-im/slack/Manifest b/net-im/slack/Manifest
index 9a4ac3e42fc0..276794f82c64 100644
--- a/net-im/slack/Manifest
+++ b/net-im/slack/Manifest
@@ -1,2 +1,3 @@
DIST slack-desktop-4.33.90-amd64.deb 75909318 BLAKE2B aced2bf58e85ebecfcf99bc3bd0d8f3d9f712493e9de51c753f461fad0a089e578430dcc5081c8ffcdbcc62e3619b1d13a3576c25dfa0ee34e1c2c958ab06a8c SHA512 c4c21c5e2932f12ebe9d36c5ca23a7b8086acb930b585d199b2499e992599dcfc3157325799364d62678feafc3ce5186f05dbb23728106a727fd9ff35d55eeb7
DIST slack-desktop-4.34.115-amd64.deb 78183906 BLAKE2B 13c16a1aed2efbd04298216116b02ca7bfabec48d08184512cad3f770b58304b687eea223885b79fce5353efe5fb77aadd05b07d0adcf6b563e0b9aceef7c43e SHA512 7f1854c9328e8f099e232cf7dad6ef2365755cb84ac79b92b78cdf13a316865d0095bd22af6ba1ab69d0ed8a0a633a2c525f1a608765136514d73bff23449161
+DIST slack-desktop-4.34.120-amd64.deb 78115758 BLAKE2B 0f695c71627f0c5ee272874db11260d751deac72e25419b3574df49f670345603d6358fa84c2847f881a9195e11feb5d340554c856275dad881480c15e5e14f6 SHA512 d886d43c1f061c1b81f6117646e1d1ff849c9f98accb37994763572e75178c0e68ffdaaaba36e5322d9bd5b023de5f19ac6b7efd541ff7c963ea792258f7ecb4
diff --git a/net-im/slack/slack-4.34.120.ebuild b/net-im/slack/slack-4.34.120.ebuild
new file mode 100644
index 000000000000..f0291e2700fa
--- /dev/null
+++ b/net-im/slack/slack-4.34.120.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop multilib-build optfeature pax-utils unpacker xdg
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="https://slack.com"
+SRC_URI="https://downloads.slack-edge.com/releases/linux/${PV}/prod/x64/${PN}-desktop-${PV}-amd64.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="appindicator +seccomp suid wayland"
+RESTRICT="bindist mirror"
+
+RDEPEND="app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/mesa:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libdrm:0[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]
+ appindicator? ( dev-libs/libayatana-appindicator )"
+
+QA_PREBUILT="opt/slack/chrome-sandbox
+ opt/slack/chrome_crashpad_handler
+ opt/slack/libEGL.so
+ opt/slack/libGLESv2.so
+ opt/slack/libffmpeg.so
+ opt/slack/libvk_swiftshader.so
+ opt/slack/libvulkan.so.1
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/slack
+ opt/slack/swiftshader/libEGL.so
+ opt/slack/swiftshader/libGLESv2.so"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # remove hardcoded path, logging noise (wrt 694058, 711494)
+ sed -i -e '/Icon/s|/usr/share/pixmaps/slack.png|slack|' \
+ -e '/Exec/s|slack|slack -s|' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed in Icon for slack.desktop"
+
+ if use appindicator ; then
+ sed -i '/Exec/s|=|=env XDG_CURRENT_DESKTOP=Unity |' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for appindicator"
+ fi
+
+ if ! use seccomp ; then
+ sed -i '/Exec/s/%U/%U --disable-seccomp-filter-sandbox/' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for seccomp"
+ fi
+
+ if use wayland ; then
+ sed -i '/Exec/s/%U/%U --enable-features=WebRTCPipeWireCapturer/' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for wayland"
+ fi
+
+ rm usr/lib/slack/LICENSE{,S-linux.json} \
+ || die "rm licenses failed"
+}
+
+src_install() {
+ doicon usr/share/pixmaps/slack.png
+ doicon -s 512 usr/share/pixmaps/slack.png
+ domenu usr/share/applications/slack.desktop
+
+ insinto /opt # wrt 720134
+ cp -a usr/lib/slack "${ED}"/opt || die "cp failed"
+
+ use suid && fperms u+s /opt/slack/chrome-sandbox # wrt 713094
+ dosym ../../opt/slack/slack usr/bin/slack
+
+ pax-mark -m "${ED}"/opt/slack/slack
+
+ # https://bugs.gentoo.org/898912
+ if use appindicator; then
+ dosym ../../usr/lib64/libayatana-appindicator3.so /opt/slack/libappindicator3.so
+ fi
+}
+
+pkg_postinst() {
+ optfeature "storing passwords via gnome-keyring" app-crypt/libsecret
+
+ xdg_pkg_postinst
+}