summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-11-24 00:03:33 +0200
committerJimi Huotari <chiitoo@gentoo.org>2024-12-07 17:51:36 +0200
commitdb08cc147b7ce4f6729e49428b815b03dd688de8 (patch)
tree2aa112e5d39e5bc15d62cd2db7d5603e643f9ffb /net-im/qtox
parentdev-python/phonenumbers: Remove old (diff)
downloadgentoo-db08cc147b7ce4f6729e49428b815b03dd688de8.tar.gz
gentoo-db08cc147b7ce4f6729e49428b815b03dd688de8.tar.bz2
gentoo-db08cc147b7ce4f6729e49428b815b03dd688de8.zip
net-im/qtox: build 9999 with qt 6 and switch to a new upstream
Also remove the now unused toxest-related dependencies, and update CMake switches. As the original project repository [1] is archived, this switches the upstream to a fork [2] by people working on 'net-libs/tox' as well. Segfault on exit when spellcheck is enabled is fixed here too. 1. https://github.com/qTox/qTox/ 2. https://github.com/TokTok/qTox/ Bug: https://bugs.gentoo.org/895634 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'net-im/qtox')
-rw-r--r--net-im/qtox/qtox-9999.ebuild58
1 files changed, 22 insertions, 36 deletions
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index efe18c5045f9..3b1a26bd42fa 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,11 +7,11 @@ inherit cmake xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/qTox/qTox.git"
+ EGIT_REPO_URI="https://github.com/TokTok/qTox.git"
else
MY_P="qTox-${PV}"
- SRC_URI="https://github.com/qTox/qTox/releases/download/v${PV}/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/TokTok/qTox/releases/download/v${PV}/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
S="${WORKDIR}/qTox"
fi
@@ -20,65 +20,51 @@ HOMEPAGE="https://qtox.github.io/"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+spellcheck test X"
-
-RESTRICT="!test? ( test )"
+IUSE="spellcheck X"
BDEPEND="
- dev-qt/linguist-tools:5
+ dev-qt/qttools:6[linguist]
virtual/pkgconfig
"
RDEPEND="
dev-db/sqlcipher
dev-libs/libsodium:=
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5[gif(+),jpeg,png,X(-)]
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
+ dev-qt/qtbase:6[concurrent,gui,network,opengl,widgets,xml]
+ dev-qt/qtsvg:6
media-gfx/qrencode:=
media-libs/libexif
media-libs/openal
media-video/ffmpeg:=[webp,v4l]
- >=net-libs/tox-0.2.13:=[av]
- >=net-libs/toxext-0.0.3
- >=net-libs/tox_extension_messages-0.0.3
- spellcheck? ( kde-frameworks/sonnet:5 )
+ >=net-libs/tox-0.2.20:=[av]
+ spellcheck? (
+ || (
+ kde-frameworks/sonnet:6[aspell]
+ kde-frameworks/sonnet:6[hunspell]
+ )
+ )
X? (
+ dev-qt/qtbase:6=[X]
x11-libs/libX11
x11-libs/libXScrnSaver
)
"
DEPEND="${RDEPEND}
- test? ( dev-qt/qttest:5 )
X? ( x11-base/xorg-proto )
"
DOCS=( CHANGELOG.md README.md doc/user_manual_en.md )
-src_prepare() {
- cmake_src_prepare
-
- # bug 628574
- if ! use test; then
- sed -i CMakeLists.txt -e "/include(Testing)/d" || die
- sed -i cmake/Dependencies.cmake -e "/find_package(Qt5Test/d" || die
- fi
-}
-
src_configure() {
local mycmakeargs=(
+ -DASAN=OFF
-DPLATFORM_EXTENSIONS=$(usex X)
- -DUPDATE_CHECK=OFF
- -DUSE_CCACHE=OFF
-DSPELL_CHECK=$(usex spellcheck)
- -DSVGZ_ICON=ON
- -DASAN=OFF
- -DDESKTOP_NOTIFICATIONS=OFF
-DSTRICT_OPTIONS=OFF
+ -DSVGZ_ICON=ON
+ -DTSAN=OFF
+ -DUBSAN=ON
+ -DUPDATE_CHECK=OFF
+ -DUSE_CCACHE=OFF
)
[[ ${PV} != 9999 ]] && mycmakeargs+=( -DGIT_DESCRIBE=${PV} )