summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-10-19 11:36:02 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-10-19 11:36:16 +0200
commitc10c0fdc70840219621339b61c94126c5a9c82da (patch)
tree040f990ebc92da8445fa074b2610e83c6aae571f /net-ftp
parentwww-servers/varnish: amd64 stable wrt bug #562282 (diff)
downloadgentoo-c10c0fdc70840219621339b61c94126c5a9c82da.tar.gz
gentoo-c10c0fdc70840219621339b61c94126c5a9c82da.tar.bz2
gentoo-c10c0fdc70840219621339b61c94126c5a9c82da.zip
net-ftp/filezilla: fix patches cleanup
The wrong file was removed in 92b578678a2ad86dfff37a9ba024461629785c6f Package-Manager: portage-2.2.23
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/files/filezilla-3.10.2-debug.patch13
-rw-r--r--net-ftp/filezilla/files/filezilla-3.13.0-fzputtygen_interface.h40
2 files changed, 13 insertions, 40 deletions
diff --git a/net-ftp/filezilla/files/filezilla-3.10.2-debug.patch b/net-ftp/filezilla/files/filezilla-3.10.2-debug.patch
new file mode 100644
index 000000000000..74e3fc30ea21
--- /dev/null
+++ b/net-ftp/filezilla/files/filezilla-3.10.2-debug.patch
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2015-03-03 17:04:56.300296016 +0100
++++ configure.ac 2015-03-03 17:05:20.739299967 +0100
+@@ -46,8 +46,8 @@
+ if ! test "$localesonly" = "yes"; then
+
+ if test "X$GCC" = Xyes; then
+- CFLAGS="$CFLAGS -Wall -g"
+- CXXFLAGS="$CXXFLAGS -Wall -g"
++ CFLAGS="$CFLAGS -Wall"
++ CXXFLAGS="$CXXFLAGS -Wall"
+ fi
+
+ # Check for C++11 support
diff --git a/net-ftp/filezilla/files/filezilla-3.13.0-fzputtygen_interface.h b/net-ftp/filezilla/files/filezilla-3.13.0-fzputtygen_interface.h
deleted file mode 100644
index b72d47005f01..000000000000
--- a/net-ftp/filezilla/files/filezilla-3.13.0-fzputtygen_interface.h
+++ /dev/null
@@ -1,40 +0,0 @@
-#ifndef FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER
-#define FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER
-
-#include <wx/process.h>
-
-class CFZPuttyGenInterface
-{
-public:
- CFZPuttyGenInterface(wxWindow* parent);
- virtual ~CFZPuttyGenInterface();
- bool LoadKeyFile(wxString& keyFile, bool silent, wxString& comment, wxString& data);
-
- void EndProcess();
- void DeleteProcess();
- bool IsProcessCreated();
- bool IsProcessStarted();
-
-protected:
- // return -1 on error
- int NeedsConversion(wxString keyFile, bool silent);
-
- // return -1 on error
- int IsKeyFileEncrypted(wxString keyFile, bool silent);
-
- wxProcess* m_pProcess{};
- bool m_initialized{};
- wxWindow* m_parent;
-
- enum ReplyCode {
- success,
- error,
- failure
- };
-
- bool LoadProcess(bool silent);
- bool Send(const wxString& cmd);
- ReplyCode GetReply(wxString& reply);
-};
-
-#endif /* FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER */