summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-12-03 11:16:38 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-12-03 11:16:38 -0800
commit61c556d2b8c26c6b08ec13f30c908caa546558d1 (patch)
tree6a2ac6a4ab98d9f586e79d46eea22b895095ba03 /net-firewall/arptables/arptables-0.0.5-r2.ebuild
parentapp-eselect/eselect-iptables: Version bump, fix aprtables handling (diff)
downloadgentoo-61c556d2b8c26c6b08ec13f30c908caa546558d1.tar.gz
gentoo-61c556d2b8c26c6b08ec13f30c908caa546558d1.tar.bz2
gentoo-61c556d2b8c26c6b08ec13f30c908caa546558d1.zip
net-firewall/arptables: Revbump, update esel-ipt dep (bug #828064)
Closes: https://bugs.gentoo.org/828064 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-firewall/arptables/arptables-0.0.5-r2.ebuild')
-rw-r--r--net-firewall/arptables/arptables-0.0.5-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-firewall/arptables/arptables-0.0.5-r2.ebuild b/net-firewall/arptables/arptables-0.0.5-r2.ebuild
new file mode 100644
index 000000000000..fee032c21db6
--- /dev/null
+++ b/net-firewall/arptables/arptables-0.0.5-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="set up, maintain, and inspect the tables of ARP rules in the Linux kernel"
+HOMEPAGE="http://ebtables.sourceforge.net/"
+SRC_URI="ftp://ftp.netfilter.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+BDEPEND=">=app-eselect/eselect-iptables-20211203"
+RDEPEND="${BDEPEND}"
+
+src_compile() {
+ # -O0 does not work and at least -O2 is required, bug #240752
+ emake CC="$(tc-getCC)" COPT_FLAGS="-O2 ${CFLAGS//-O0/-O2}"
+ sed -e 's:__EXEC_PATH__:/sbin:g' \
+ -i arptables-save arptables-restore || die "sed failed"
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}"/ \
+ LIBDIR="${ED}/$(get_libdir)" \
+ SYSCONFIGDIR="${ED}"/etc \
+ MANDIR="${ED}"/usr/share/man \
+ install
+
+ newman arptables-legacy.8 arptables.8
+}
+
+pkg_postinst() {
+ if ! eselect arptables show &>/dev/null; then
+ elog "Current arptables implementation is unset, setting to arptables-legacy"
+ eselect arptables set arptables-legacy
+ fi
+
+ eselect arptables show
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} ]] && has_version 'net-firewall/iptables[nftables]'; then
+ elog "Resetting arptables symlinks to xtables-nft-multi before removal"
+ eselect arptables set xtables-nft-multi
+ else
+ elog "Unsetting arptables symlinks before removal"
+ eselect arptables unset
+ fi
+}